Cruise - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-23-2014, 08:13 AM Thread Starter
Compression Ignition Addict
 
Fosterslaw77's Avatar
 
Join Date: Jun 2012
Location: Taunton ma
Posts: 194
Thanks: 1
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Cruise

2006 f 350 84k
Went to use cruise yesterday... Nothing. Worked fine last week. Push button then set and no light comes on and cruise doesn't work. Everything else works fine. Is there a fuse I couldn't find one. Help appreciated thanks
Fosterslaw77 is offline  
post #2 of 2 Old 02-23-2014, 11:27 AM
Premium Member
 
midnite rider's Avatar
 
Join Date: Feb 2013
Location: Washington, PA
Posts: 2,353
Thanks: 118
Thanked 95 Times in 94 Posts
Mentioned: 3 Post(s)
Quoted: 276 Post(s)
Feedback Score: 0 reviews
If there is no fuse but would think it should have one, or a relay of some sort. Then it could be the clock spring, but u do not have that many miles on you rig. Although stranger things have happened. hope that helps.

-Tom

05 250 KING RANCH CCSB,278k,ARP's,SCT TSX,Atlas 40,STC done,Glowshift FP Gauge,Banks IC System,Blue Spring,Banjo's,CCV mod,Oil Bypass,Diamond Eye 5" Exhaust,Bilstein 5100's,RC Dual Steering Stabilizer,Retro 55W 6k Heads 3k Fogs,Continental Airbags,RSD 48 gal Aux Fuel Tank.





2003 F350 Lariat CCSB, 288K, Everything But Studs.
midnite rider is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome