03 with engine problems - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-30-2008, 12:31 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 with engine problems

My buddy's 03 6.0 is having some weird problems. First from a cold start if he does not plug block heater in it runs real rough until warm when temps are below 70 F outside. This has been on going issue, but since we live in south Alabama he has not looked into it. Recently it started to idle up high and then kill at red lights or when stopped in gear. It immediately restarts and will eventually do it again a little while later. I don't know if this could be injectors or hpop or some type of fuel issue. Any help is appreciated. Keep in mind this is a stock truck with original owner and 150, 000 miles I think 03 original injectors as well. Money is tight and was trying to see if we could diagnose problem before bringing to dealer and having a ton of money spent on diagnosicts if we could fix at home.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-30-2008, 12:36 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
My truck last year was having hard/no start issues as well as rough idle.

Ford replaced three injectors, HPOP, and fuel pump.
Reply With Quote Quick reply to this message
  #3  
Old 10-30-2008, 02:35 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Dallas TEXAS
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
your cold start issue should be fixed with a reflash of the PCM by the dealer and the surging and dying... I would look at the ICP sensor and connector first but thats diagnosing from a computer in Texas..LOL!
Reply With Quote Quick reply to this message
  #4  
Old 12-03-2008, 10:51 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2008
Location: NM
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thomas5853
How long did it take the dealership to replace all those parts? I just dropped my 03 off for possible Injector 2 & 4 problems.
Reply With Quote Quick reply to this message
  #5  
Old 12-03-2008, 01:07 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Three days and I had it back.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors