6.0 no low oil pressure - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-12-2014, 07:56 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Location: Nashville , GA
Posts: 822
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 no low oil pressure

Ok guys I've got a 05 with 6.0 the oil cooler went bad and I replaced it but I have not been able to get it to start back up.
I found no low oil pressure so I checked the regulator all seemed fine pulled the lpop out looks like a snap ring went threw it. So I put new gears and a new oil pump cover since the old one was scratched up. Put everything back together.
I'm still not getting any oil coming into the filter housing. So I pulled the oil regulator again the spring and bolt come out with ease but the cylinder hangs up in the bore have to take a pick to pull it out. I've tried cleaning it to no avail. It's got a oem cap and filter. Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-13-2014, 06:02 AM
Member
 

Join Date: Jul 2013
Location: Kennewick
Posts: 51
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I'm courious how long of cranks and how many times have you tried to start truck ? I did my oil cooler last fall and it did take a long time to start with many attempts . I'm sure someone on here will be able to point you in the right direction. Sounds like an Issue the 6.0 guys might want to follow.
Reply With Quote Quick reply to this message
  #3  
Old 02-13-2014, 06:04 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Location: Nashville , GA
Posts: 822
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have cranked on it about 12 times in 15 to 20 sec burst. In ready to get this thing back goin I've been in my 7.3 for a week now lol
Reply With Quote Quick reply to this message
  #4  
Old 02-13-2014, 06:15 AM
Member
 

Join Date: Jul 2013
Location: Kennewick
Posts: 51
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Don't know if this will help It takes my truck and another 6.0 I have access to, to double check my findings about 7-10 seconds to fill a oil bowl when empty, I recently put in a oil pressure gauge coming off my Oil cap and I noticed it shows psi before the factory dummy gauge does which to me is strange cause the factory sensor is lower than the oil cap gauge
Reply With Quote Quick reply to this message
  #5  
Old 02-13-2014, 06:17 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Location: Nashville , GA
Posts: 822
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah even after I've replaced the lpop and cover I'm still not getting any oil in the filter housing even in a 20 sec crank
Reply With Quote Quick reply to this message
  #6  
Old 02-13-2014, 06:22 AM
Member
 

Join Date: Jul 2013
Location: Kennewick
Posts: 51
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Humm well I'm to novice with the 6.0 to offer any good info on this issue, seems somethings simple as it was fine before the oil cooler replacement. I did alot of searching and post reading when I had injector issues and came across alot of older threads with the right info to get me going in the right direction. Hope someone has something to offer for advice
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors