Random Power Loss / EGR quesiton - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-12-2014, 06:17 AM
Member
 

Join Date: Apr 2010
Location: Boulder County
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Random Power Loss / EGR quesiton

Hey all... Im looking for help with a random loss of power issue I am having.

Every so often, when I accelerate I have a loss of power and black smoke... I let off the throttle and step into in again and it clears up and its back to normal. I cant seem to pinpoint when or why and it seems rather random.

No DTCs and using Dashboss all my numbers seem to be ok.

I am kinda thinking a sticking EGR valve.. I cleaned it and put on new O-rings and it still is acting up. Thinking maybe replace it?

On a side note, should by "EGR command %" and "EGR desired" numbers be the same?

Truck is a 2004 F250 with 175K miles... all stock except for cat-back exhaust and KN intake. I just passed emissions last week with work within the last year to include:

new EGR cooler and oil cooler
new FICM
injector #2 replaced
2 new batts and new alternator
new power steering pump and gear box
new tie rods all around
new ball joints and u-joints all around
blue spring upgrade

Any other ideas or thoughts? thanks for the help!

Last edited by trujillo417; 02-12-2014 at 08:07 AM. Reason: update
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-12-2014, 08:08 AM
Member
 

Join Date: Apr 2010
Location: Boulder County
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could this also be caused by dirty/clogged turbo veins? Anyone have a decent write up on how to split the turbo and clean it or is it better to send it to a pro or replace it?
Reply With Quote Quick reply to this message
  #3  
Old 02-12-2014, 03:26 PM
Compression Ignition Addict
 

Join Date: Jan 2013
Location: Whidbey Island, WA
Posts: 199
Thanks: 9
Thanked 12 Times in 10 Posts
Feedback Score: 1 reviews
It's funny you bring this up. I'm having the same exact problem since putting my truck back to the stock tune from a tune that turns off the EGR.
It's done this before but I just chalked it up to it needing to relearn but I never drove on it very long before going back to the performance tune.

Sometimes but not all the time I get a delay in acceleration and smoke out the exhaust. If I go back to the performance tune I have absolutely no issues.
I've driven over 500 miles on it with the stock tune and it's still doing it intermittently.

I was suspecting maybe a slow or sticking EGR even though I cleaned it and put new rings on it about 3000 miles ago.

Last edited by Soledad; 02-12-2014 at 03:33 PM.
Reply With Quote Quick reply to this message
  #4  
Old 02-12-2014, 03:34 PM
Member
 

Join Date: Apr 2010
Location: Boulder County
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did notice that if I really step into it, I don't have any issue at all. I think its more when I accelerate slowly but Im not 100% sure yet.
Reply With Quote Quick reply to this message
  #5  
Old 02-12-2014, 04:26 PM
Member
 

Join Date: Nov 2010
Location: Mcadoo, Pa
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just had a sticky egr valve replaced. I have an 05 6.0 that was worked on recently, new egr cooler from BPD , new injectors. I drove the truck home when the work was finished, truck ran great before it came up to temp, once it was up to temp and I came to a stop, the truck was very sluggish off the line for a few seconds and the throttle came back and it ran great agian. I told the dealer about the issue and they took a look at the truck. I have a scann gauge 2 and it showed no codes. The dealer hooked into my truck and got code p0404 egr A range. The side note on receipt stated; performance showing 83% open, remove and replace egr valve and retested at 0% ~ good. New egr valve from napa was 251.00. They just charged me for the part and said they should have caught it on the when they test ran my truck. I hope this helps, good luck. I had 156k on the original egr valve.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors