Electrical Problem ? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-04-2014, 05:01 PM
Powerstroke.org Rookie
 

Join Date: Feb 2014
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical Problem ?

hey guys I need some help. My 04 6.0 L battery lite came on today. when i got to work the ABS light came on . had 12.1 volts on each battery. cleaned the terminals ( there was a little corrosion) when i tried to start it just clicked. finally got it started back up. after 10 minutes the instrument cluster went dead then the truck died. any ideas??? nothing at all works.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-04-2014, 05:41 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2010
Posts: 99
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
your alternator may have died, mine did the same thing.
Reply With Quote Quick reply to this message
The Following User Says Thank You to bottomland4x4 For This Useful Post:
dougggie (02-05-2014)
  #3  
Old 02-04-2014, 11:13 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,467
Thanks: 0
Thanked 18 Times in 18 Posts
Feedback Score: 0 reviews
You need to seperate the batteries and load test them individualy. You may have enough volts but not enough amps available.

Also you cleaned the wires but did you also clean the grounds. You may not be completeing circuit.
Reply With Quote Quick reply to this message
The Following User Says Thank You to dannyboy950 For This Useful Post:
dougggie (02-05-2014)
  #4  
Old 02-05-2014, 05:18 AM
Powerstroke.org Rookie
 

Join Date: Feb 2014
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks but It is a new, (less than 1 1/2 yr ) alt
Reply With Quote Quick reply to this message
  #5  
Old 02-05-2014, 05:19 AM
Powerstroke.org Rookie
 

Join Date: Feb 2014
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks but it is less than 1 1/2 year old...
Reply With Quote Quick reply to this message
  #6  
Old 02-06-2014, 05:40 AM
Compression Ignition Addict
 

Join Date: Dec 2012
Location: Garson, MB, CAN
Posts: 164
Thanks: 42
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Sounds like your running off the batteries.
Even an alt 1 1/2 yr old can go bad.
When its running have you tried checking voltage alt is charging at?
Needs to be a min of 13.6. Anything lower and these electronics just dont like it.
And again, get batteries load tested. Bad alt can eat up a good set of batteries.

I've read somewhere too that if the voltage isn't at a minumum number, the computer won't trigger truck to fire. But can't remember where I read it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors