Truck died while driving.. No power at all... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 01-29-2014, 07:08 AM Thread Starter
Member
 
fordoffroader101's Avatar
 
Join Date: Jun 2009
Location: novato
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Truck died while driving.. No power at all...

I was driving to work this morning in my 2004 6L 200k miles. As i was driving the motor died and everything went out... All the electrical. Truck wouldnt even turn over. None of the gauges work, headlights dont come on... nothing. Its been having hard starts and I was leaning towards the FICM but could the FICM cause this or could it be sommething as dumb as a loose battery terminal? Never seen a truck die like that. Really need some help...
fordoffroader101 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-29-2014, 07:29 AM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 66 Times in 62 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Probably battery or cable. When voltage drops below 8vlt the PCM and FICM quit working which means everything they control quits working also.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #3 of 6 Old 01-29-2014, 07:34 AM Thread Starter
Member
 
fordoffroader101's Avatar
 
Join Date: Jun 2009
Location: novato
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
nothing would come on at all after it died out on me. Even with the key on the ON position the glow plugs dont fire up or anything.
fordoffroader101 is offline  
post #4 of 6 Old 01-29-2014, 07:38 AM
Compression Ignition Addict

 
sbluke55's Avatar
 
Join Date: Sep 2013
Location: Grand Junction, CO
Posts: 7,142
Thanks: 291
Thanked 556 Times in 528 Posts
Mentioned: 14 Post(s)
Quoted: 471 Post(s)
Garage
Feedback Score: 1 reviews
I've had this happen on a old Chevy once. The lead to the starter got to close to the exhaust and shorted out and shut everything off. It caused such bad corrosion on the battery terminal that there was no power to the truck. I cleaned the connections and taped up the bad spot and she fired right up. It's worth a shot. Hope this helps.


Sent from AutoGuide.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
01 f-250, Standard
Rev tech 4" lift,37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks inner cooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sbluke55 is offline  
post #5 of 6 Old 01-29-2014, 07:45 AM Thread Starter
Member
 
fordoffroader101's Avatar
 
Join Date: Jun 2009
Location: novato
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
worth a shot.. hopefully it stops snowing here soon so i can get under the hood and check it out...
fordoffroader101 is offline  
post #6 of 6 Old 01-29-2014, 07:48 AM
Compression Ignition Addict

 
sbluke55's Avatar
 
Join Date: Sep 2013
Location: Grand Junction, CO
Posts: 7,142
Thanks: 291
Thanked 556 Times in 528 Posts
Mentioned: 14 Post(s)
Quoted: 471 Post(s)
Garage
Feedback Score: 1 reviews
If that is the case I would get all new cables and battery's. I just did the tape job as a quick fix to get me home


Sent from AutoGuide.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
01 f-250, Standard
Rev tech 4" lift,37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks inner cooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sbluke55 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome