charging issues, low voltage, help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-22-2014, 02:12 PM Thread Starter Rookie
Join Date: Aug 2011
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
charging issues, low voltage, help

so since we started getting this cold weather my truck has had some starting and charging issues, the dash has nothing, blower motor is weak and after the truck gets warm it all comes up and is fine, no codes. i replaced the alternator beacuse it was only putting out 12.6 volts new one is 13.8-14.6, and has two new batteries, what i have noticed is the alternator wont charge until the dash comes up, sometimes acts like batteries are dead just clicks but after 10 minutes or so it will start right up, all the grounds look good battery cables are tight and if it is over 30 degrees out it has no issues.. really need some help here dont know where to go next. its a 04 6.0 auto trans, ec, sb, 4wd

2004 F350 FX4 4 inch turbo back mbrp cat delete, 07 harley davidson headlights, zoodad, blue spring, REV-X,hot shots secret, volant cold air intake
BigRed Rig is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome