Have a Code P0004 PLS Help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-14-2008, 07:18 PM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
Exclamation Have a Code P0004 PLS Help

My F250 6.0l with 42K has a code P0004, the fuel gauge when to E and the dash gave a fuel data error. the CEL is on also. Can anyone help, I do know that the error is Fuel Volume Regulator Control Circuit High. But I do not know what that means. Can anyone help, also will this be covered under the warranty for the Eng 100K warranty???? I only have a AFE intake and exhaust, and a SCT with Dj tunes. Thanks for your help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-15-2008, 10:29 AM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
Can anyone help???

Are there any Powerstroke Techs that can help me on this????
Reply With Quote Quick reply to this message
  #3  
Old 09-15-2008, 10:36 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,059
Thanks: 112
Thanked 95 Times in 87 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
There are a couple techs that will be on at some point today. Bump your post later it will be seen
Reply With Quote Quick reply to this message
  #4  
Old 09-18-2008, 01:45 PM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
Powerstroke Techs PLS Help

Powerstroke techs pls help.......

Reply With Quote Quick reply to this message
  #5  
Old 09-18-2008, 06:31 PM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
Anyone anyone

Reply With Quote Quick reply to this message
  #6  
Old 10-08-2008, 07:32 PM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
Can anyone help

anyone anyone.....
Reply With Quote Quick reply to this message
  #7  
Old 10-08-2008, 08:29 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
what year is it? and also are you sure about that code number cause i can't find that number in any of the pced books. the lowest number is a p0046 and that is is for boost control solenoid circuit performance.
Reply With Quote Quick reply to this message
  #8  
Old 10-09-2008, 09:26 AM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
more info

it is a 2006 F250 CC KR 4x4. when I read the code with my SCT it says P0004. I have looked the code up on the internet and found it to be "P0004 - Fuel Volume Regulator Control Circuit High".
When this happens the fuel gauge goes to E and the dash gives a fuel data error and the check engine light comes on. I have cleared the error twice and it has come back.
Reply With Quote Quick reply to this message
  #9  
Old 12-22-2008, 08:54 PM
Powerstroke.org Fanatic
 

Join Date: Sep 2008
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have an 07 PSD throwing P004 too. What is the part I need to replace, and where is it located? Mine still runs fine, but the wrench light shines.
Reply With Quote Quick reply to this message
  #10  
Old 12-23-2008, 06:05 AM
Member
 

Join Date: Nov 2007
Location: Bentonville, AR
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Sandman77
***UPDATE***

This problem has not occured after the last time that I cleared it over a month ago. I talked to the local Ford dealer about it, and their diesel techs do not have a clue what it is. I guess I will wait and see if it reappears... If you ever find out what it is, post it here...

Good Luck in finding the cause, hopefully it just disappears like mine and you can get back to :burnout
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:14 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors