No POWER at low RPM and vibration in overdrive - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-29-2008, 10:29 AM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No POWER at low RPM and vibration in overdrive

Couple issues that I wanted to see if anyone had some ideas. I have a 2003 F350 dually with the 6.0L and have been reading on the blog and have a couple of different questions. I had the computer flashed about a year ago and it seemed to help the problem starting when cold and the low power at low RPM, but it has seemed to get worse again. Not sure if my Bully Dog Dyno Dominator caused the problem, but I have recently removed it and wondered if it could have affected the computer and I would need a reflash? Also, anytime I am in overdrive below 65 mph I get a vibration, more noticeable under load or trying to accelerate. I have an ATS transmission and last year had to reinstall a couple bolts from the flywheel to the torque converter. I checked it again and they seem to be tight. Ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-29-2008, 10:56 AM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Try cleaning your EGR valve to help with your power. Check your weights on the driveshaft. I had a weight fall off and it made my truck vibrate real good under 65mph. Just a couple of ideas to start with.
Reply With Quote Quick reply to this message
  #3  
Old 02-27-2011, 10:09 PM
Powerstroke.org Rookie
 

Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation vibration at low rpm/speed

Seems i have a common problem I own a 6.0ltr 2003 f350 lariat single axel crew cab which I love anyways I'm experiencing a shake in the truck at around 1800rpm 30-45 mph in town it goes away if I downshift or put in tow mode seems to be in sync with engine turnover maybe a weak injector? This is my first diesel so please help lcso2nddb@gmail.com
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:26 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors