03 oil leaking from the back of motor - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-23-2008, 06:57 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 oil leaking from the back of motor

Pulled in to the house last night and instantly found oil dripping from under the trans / motor . First thought was rear main but looks like its coming from higher up .. Anybody know where this might be coming from? Help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-23-2008, 07:05 PM
aluminum tubing engineer
 

Join Date: May 2007
Location: sacramento
Posts: 1,285
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
...have you done the ccv mod yet?
Reply With Quote Quick reply to this message
  #3  
Old 08-23-2008, 07:10 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no what is the ccv mod
Reply With Quote Quick reply to this message
  #4  
Old 08-23-2008, 07:20 PM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It could be the bedplate seal. It is a common issue with the 6.0, but it is not a cheap or easy fix. Good luck.
Reply With Quote Quick reply to this message
  #5  
Old 08-23-2008, 08:08 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I think its coming from up higher then the bedplate seal. It looks like its coming from the back of the head or the back of the turbo area . I started to pull the turbo but couldnt get the rear turbo mounting bolt off ..
Reply With Quote Quick reply to this message
  #6  
Old 08-23-2008, 08:24 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
More than likely it's your ICP sensor leaking - I've replaced many on the 03'-04' 6.0l.
Reply With Quote Quick reply to this message
  #7  
Old 08-23-2008, 09:37 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Las Vegas, Nevada
Posts: 1,039
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Yup, its probably your ICP sensor, no need to pull your turbo to replace it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors