Electrical Problems - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2008, 03:47 AM
Powerstroke.org Rookie
 

Join Date: Feb 2008
Location: Miami
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical Problems

05 PSD Excursion...Battery indicator lights up on ocassion, mostly when the truck is cold, then turns off after app 15 minutes. When the indicator turns on, the electrical system to include radio, lights and gauges flicker on and off along with the battery indicator. I have thrown a volt meter on the batteries both with the truck on and off. When the truck is off, voltage is app 12.95 on each battery, when the truck is on voltage is app 13.75 on each, both when the battery indicator is lit or not lit. Truck is running absolutely fine even when the indicator light turns on, no setbacks at all.

My guess is the voltage regulator in the alternator is pms'ing. Any suggestions or advise? Thanks!

Last edited by tbaste; 08-21-2008 at 06:19 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-21-2008, 04:04 PM
Premium Member
 

Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Your going to have to test the charging system with a carbon pile. it may be fine with voltasge with no load, but once you but a load on you lose amperage, so it needs to be load tested.
Reply With Quote Quick reply to this message
  #3  
Old 08-21-2008, 05:24 PM
Powerstroke.org Rookie
 

Join Date: Feb 2008
Location: Miami
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Being an electrician, I can totally understand your response. However, I am totally clueless as to what you mean by a carbon pile. Can you explain? Thanks!
Reply With Quote Quick reply to this message
  #4  
Old 08-21-2008, 05:57 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: monroe mich
Posts: 214
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what he mean a carbon pile is aload test your alt may no be putting out enough amp to keep up with glow plug they draw 100 amp or it could be engine to body ground that will play h-ll on guages like fuel going up and down and the flikering good luck
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:22 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors