Injector question - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-12-2013, 03:56 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injector question

Hey guys, I recently purchased a 2004 powerstroke f350. The truck is in the shop now due to a issue. When everything is fully warmed up in the truck, I would get a shudder around 2k rpm in every gear only when i accelerate. overdrive there was no shuddering. The problem would get worse the more I drive it until I let it sit for a hour or so. Mechanic said I had 2 bad injectors and found 1 injector without copper washer. So thats 3 on one side of engine. It would run rough cold but ran good warm. Engine seemed like it ran fine but he thinks it's causing my shuddering when I'm accelerating. Shifting will start getting harsh and shuddering will keep getting worse longer I drive it untill I let it sit for a hour or so
any help guys?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2013, 07:14 AM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,666
Thanks: 4
Thanked 58 Times in 54 Posts
Feedback Score: 0 reviews
It sound like you are getting help. Just ensure you are not taken for a ride. With one injector not sealing, that can damage others if run like that for a while.
Reply With Quote Quick reply to this message
  #3  
Old 11-13-2013, 11:56 AM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If the injector wasn't sealing properly then combustion gases could've leaked back into the fuel rail and contaminated the fuel with air. That would explain the rough running but not the shaking or the fact it only does it when warm


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 11-13-2013, 02:15 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hmmm. Well I bought the truck with the issue. They had 2 injectors fix on one side. Then I guess 2 more started miss firing on the other side. And discover a 3rd injector had no copper washing lol. So I replaced all 4 injectors and glow plugs but cylinder 6 is still miss firing so mybe a wire issue. When I first drive the truck it will drive like a dream down the road if engine is already warmed up before driving. It shifts and accelerates great, But after 10 min of driving, the issue slowly starts occurring. It will make a jerking/shuddering/shaking accelerating normal but only shudders around 2k rpms l. I can either baby it or punch the throttle to stop the shudder sometimes. I think its tranny, but mechanics wanted the injectors fixed first. It been a waiting game for me lol he has had truck almost. 3 weeks
Reply With Quote Quick reply to this message
  #5  
Old 11-13-2013, 02:20 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Transmission runs great and shifts great until everything starts getting normal temps. Then it gets a slow shudder then start shifting kinda harsh and shakes accelerating so I hope anyone heard of the issue. Cannot find anybody that's had the issue before.
Reply With Quote Quick reply to this message
  #6  
Old 11-13-2013, 04:33 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 517
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
You pinpointed the problem in your original post, that missing gasket is only asking for more trouble. With that many injector problems its only a matter of time until the rest of them go. Replace the injectors that havent been replaced yet, make sure they are installed correctly WITH THE COPPER COMPRESSION WASHERS and then go from there. If you still have that shutter then its time to look further.


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #7  
Old 11-13-2013, 04:45 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok thank you! I got alot invested into the truck just worried about tranny.
Reply With Quote Quick reply to this message
  #8  
Old 11-13-2013, 04:51 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 517
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Aint that the truth! Hopefully its just the injector problems that came up. Keep us posted with what happens


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #9  
Old 11-13-2013, 04:56 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah for sure
Reply With Quote Quick reply to this message
  #10  
Old 11-20-2013, 07:26 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey guys I got truck injectors fixed. Runs alot better but I'm still getting a hopping/shaking on take off and accelerating 2k-3k rpms will shake for a slight sec then smooths out? Will only do it after the truck has been driven for a little bit. Doesn't seem like it does it everytime and also hearing a popping noise. Anyone have any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors