Uo155 code any info would be great - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 11-11-2013, 03:59 PM Thread Starter
Member
 
Join Date: May 2009
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Uo155 code any info would be great

I've been having a hell of a time with my truck this week, it first started I would loose my whole gauge cluster as well as the windows and radio and sun roof, but the truck would run fine as well as would not throw any codes, then I started to loose gauges,windows,radio, as well as a high in gear idle and it felt like the truck was starting off in 3rd gear. When the gauges come back on all is well, so finally it through the Uo155 code witch is lost communication with instrument cluster, so what to do now? Change the cluster or is it a bad wire? Any advice would be greatly appreciated
strokin629 is offline  
post #2 of 6 Old 11-11-2013, 05:01 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 62 Times in 58 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check fuses and relay also check for loose plugin to instrument cluster.
You could also have a instrument cluster module going out.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #3 of 6 Old 11-11-2013, 05:14 PM Thread Starter
Member
 
Join Date: May 2009
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I checked everything 3x's. is the cluster control module part of the cluster or separate and is that common?
strokin629 is offline  
post #4 of 6 Old 11-11-2013, 05:54 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 62 Times in 58 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It depends on the year 03-04 the module was mounted seperate. It was mounted to the back side of the inside fusebox. The cluster itself wasrepairable by a novice.

In 05 the cluster was physically able to be repaired but Ford would not sell just the parts you had to order the whole cluster.

In 06 the cluster could not be taken apart was digital and solidstate. Module is internal to the cluster and is not serviceable.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #5 of 6 Old 11-11-2013, 06:27 PM Thread Starter
Member
 
Join Date: May 2009
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Awesome information!! Thanks for your help I think this helped me narrow it down quite a bit I'm going to order a cluster throw it in and I will post back and let you know how it goes
strokin629 is offline  
post #6 of 6 Old 11-15-2013, 01:32 PM Thread Starter
Member
 
Join Date: May 2009
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well changed the cluster and the truck runs perfect now! Thanks for the help
strokin629 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome