lack of power - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-09-2013, 10:49 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lack of power

My brother has an 03 6.0 which has developed a strange problem. During acceleration off the line there is a noticeable lack of power until approx. 50mph at which time it seems to gain power but is followed by a puff of black smoke out the tailpipe and what seems to be a miss from the engine. Also on deceleration there is a series of what we call turbo farts until turbo spools down. He has pulled and cleaned the turbo and the truck is mostly stock. Any idea what could be causing this Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-12-2013, 07:06 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone have any ideas?
Reply With Quote Quick reply to this message
  #3  
Old 11-12-2013, 07:33 AM
Premium Member
 

Join Date: Aug 2013
Location: 804Va
Posts: 1,522
Thanks: 229
Thanked 49 Times in 36 Posts
Feedback Score: 3 reviews
I'll bite... is he flooring it or easing into it?
Is it his first PS?
How many miles?
What mods? Tuner, sticks, turbo?
Is it lifted, bigger tires?
How old is he?
Google turbo huff.

Last edited by Heavy_GD; 11-12-2013 at 07:45 AM.
Reply With Quote Quick reply to this message
  #4  
Old 11-12-2013, 11:43 AM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,664
Thanks: 4
Thanked 58 Times in 54 Posts
Feedback Score: 0 reviews
Sticky vanes or VGT solenoid issue. What does the monitor say about the VGT?
Reply With Quote Quick reply to this message
  #5  
Old 11-12-2013, 01:14 PM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck is mostly stock, no tuner or anything. He eases into it off the line normally. He cleaned the turbo and monitor (insight) indicates it is operating properly. Can the MAF cause this issue?
Reply With Quote Quick reply to this message
  #6  
Old 11-13-2013, 07:11 AM
Premium Member
 

Join Date: Aug 2013
Location: 804Va
Posts: 1,522
Thanks: 229
Thanked 49 Times in 36 Posts
Feedback Score: 3 reviews
Sorry OP, "mostly" stock tells us nothing and with no monitor you guys are going to be throwing darts.
Reply With Quote Quick reply to this message
  #7  
Old 11-13-2013, 11:41 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
As stated in previous post our monitor says everything is running ok...no codes. Mostly stock means no engine modifications.
Reply With Quote Quick reply to this message
  #8  
Old 11-13-2013, 04:50 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 517
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
If its not building power then you should look at two things seperately- is it building boost quickly and enough boost? Exhaust leak, cac boots and sticking vanes will cause low power without throwing a code.


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #9  
Old 11-14-2013, 07:43 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It appears to be building too much boost. The turbo was cleaned so that should eliminate the sticking vanes. We have checked boots and they all look good.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:50 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors