6.0 fuel problems? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 08-04-2008, 05:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.0 fuel problems?

I have a 2004 6.0 PSD with approx 61,000 miles. Sometimes when driving it seems like the truck starts to shake a little bit and then a loss of power. When I say a loss of power I mean You can put the pedal on the floor and the truck does nothing but idle. If you turn the truck off and try to restart it sometimes it will start ant sometimes it wont. When it doesn't restart it acts like it is not getting any fuel. I took it back to the deal (still under warranty) and they said it was something with the turbo. They fixed it and it ran good for approx 6 days then started that mess again. Any help or advice would be greatly appreciated.
wdm214 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 08-04-2008, 06:58 PM
Compression Ignition Addict
 
AvroAero's Avatar
 
Join Date: Sep 2007
Location: Bolton
Posts: 786
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have you checked your EGR valve?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 Ford Excursion 6.0
-SCT livewire w/ innovative extreme tunes
-Banks monster exhaust
-Zoodad
-05 conversion w/ harley headlamps & HIDs
-Viper 5900 remotestart/alarm
-ARP studs
-EGR delete
-Defender roof rack with 600W of light
-whelen hideaway strobes
-Sound off Predator dual red-red
-Whelen 500 4 amber 2 blue
AvroAero is offline  
post #3 of 12 Old 08-05-2008, 12:03 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have not checked the ERG valve. This is my first diesel, but I have checked everything I feel comfortable checking. Since it is still under warranty I am kind of skidish on checking to many this (don't want to give them any reason to void it). I took it back to the dealership, but I still want other knowledgable opinions on what it might be.
wdm214 is offline  
post #4 of 12 Old 08-05-2008, 01:45 PM
My 6OH Hates Me


 
mudrunninpig's Avatar
 
Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,851
Thanks: 8
Thanked 27 Times in 26 Posts
Mentioned: 1 Post(s)
Quoted: 24 Post(s)
Feedback Score: 1 reviews
It may be the egr valve. do you know if it has been replaced or cleaned? They will definetly "gunk" up quickly. They are a bear to get out to clean but with some finesse it will pop out. If you are skittish, take it to the dealer and have them replace it under warranty.

Mike





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"The Iron Pig"



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mudrunninpig is offline  
post #5 of 12 Old 08-05-2008, 01:52 PM
Powerstroke Techie

 
Clay Henry's Avatar
 
Join Date: Jul 2006
Location: Tuttle, OK
Posts: 17,250
Thanks: 1
Thanked 20 Times in 18 Posts
Mentioned: 1 Post(s)
Quoted: 25 Post(s)
Feedback Score: 0 reviews
If its the EGR valve you will close down teh highway with a cloud of smoke. Was there any smoke involved?
Any codes you could pull would help
It could be alot of things, weak pump, FICM...lots of things but codes would tell alot.

2003 6.0 F350 dually on high cholesterol fuel (WVO)
2000 7.3 Excursion also on a high cholesterol fuel




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Clay Henry is offline  
post #6 of 12 Old 08-05-2008, 02:24 PM
Compression Ignition Addict
 
KYStrokin's Avatar
 
Join Date: Mar 2006
Location: Valley Station, KY
Posts: 275
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine done the same thing, 4 bad injectors
KYStrokin is offline  
post #7 of 12 Old 08-07-2008, 01:31 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well, I spoke with the dealership today and they said they could not find anything wrong with the truck. No codes were showing up or anything. They still have the truck and looking into the problem. If they can't find anything wrong with it, I don't know what to do. I am kind of leary on getting rid of it due to the fact that I just bought the truck in March and would be to far upside down on it. Any advice would be helpful.
wdm214 is offline  
post #8 of 12 Old 08-07-2008, 01:47 PM
Compression Ignition Addict
 
jblagg's Avatar
 
Join Date: Apr 2007
Location: Alvin, TX
Posts: 828
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
good luck may be a defueling problem

03 F350 PSD
7.3 AUTO
EXT. CAB,
LWB, FX4
jblagg is offline  
post #9 of 12 Old 08-07-2008, 01:59 PM
DKR
<--Pro Cooler Racer
 
DKR's Avatar
 
Join Date: Dec 2006
Location: Newark, Delaware
Posts: 8,216
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Skype™ to DKR
Or HPOP fittings went bad.

Eric
2007 F250 6.0l King Ranch CC LB
Sponsored by Innovative Diesel Performance
SCT XCal2 w/ Custom Files & FICM tuning
DashDAQ Series II; ARP Headstuds; AFE Stage 2 XP Intake w/ Proguard 7
Industrial Injection 190cc injectors; FASS 150/180; ITP Regulated Return
'03 Turbo Swap; Zex N2O Dry Shot; CFM Smallmouth Intake Elbow
Zoodad w/ Predator Screen; MBRP 4" Cool Duals Straight Piped
EGR Delete w/ full manifold; Coolant Bypass Filter; Train Horns
Eclipse AVN62D; High Idle Mod; BFG ATs 285-65/20s

Truck- 12.51sec @ 108mph @ ~7700lbs (1/4 mi)
Cooler- 39.93sec @ 12.12mph @ ~180lbs (1/8 mi)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DKR is offline  
post #10 of 12 Old 08-08-2008, 05:38 PM
Powerstroke.org Rookie
 
Join Date: Aug 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hey all, Newbie here, don"t mean to hijack this thread, but don"t understand yet how to start a new post,,, i had a similiar problem with my truck that i just fixed today, i have an 06 6.0 psd all stock with 72000 miles on it and going down the highway it would roll the black smoke out. When i came to a stop, it didn"t want to take off, only after like 10 sec. would it take off,, all the while blowing black smoke worse than a train. Got home, and changed both fuel filters, and a new air filter, fired it back up and then it was rolling out tons of white smoke, and didn"t want to be revved up, so i recycled the fuel system again, and pulled the egr valve and cleaned it, it wasn"t too bad dirty wise, but it was just barely stuck open, cleaned it and reinstalled it, i also unhooked my batteries to reset the computer. (yes the check engine light was on) I wasn"t able to check the codes, don"t have a codereader yet. Anyway, fired it back up and it runs just like a new truck again, no smoke or anything. Don"t know if any of this will help you or not, but it did me.
surgeon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome