05 excursion 6.0 - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-22-2013, 05:43 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
05 excursion 6.0

Replaced ficm with new bulletproof half . The truck ran for two days before blowing fuel pump fuse for the first time replaced fuse and the truck still won't start. Had no problems before replacing ficm other than low circuit voltage to the injectors. Cranked several times for 30 sec. to prime but still won't start.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-22-2013, 05:57 PM
Compression Ignition Addict
 

Join Date: Jul 2013
Location: Centerport, PA
Posts: 193
Thanks: 5
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
Hmm..wondering if fuel pump is dead. Any idea what caused to to blow the fuse? That probably doesn't just happen for no good reason. That being said, I'm not sure how to diagnose that.
Reply With Quote Quick reply to this message
  #3  
Old 10-23-2013, 02:08 AM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I don't know why the fuse blew but I can
Here the pump running and the second
Filter canister is filling up with fuel.
Reply With Quote Quick reply to this message
  #4  
Old 10-23-2013, 04:57 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I call bpd and they had me send the hole ficm to them to test.
Reply With Quote Quick reply to this message
  #5  
Old 10-26-2013, 06:18 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 517
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Thats weird that the fuse blew at the same time the ficm is having issues. I have a feeling that blown fuse has something to do with the no start, not the bpd ficm. But, interested to see whats the problem.


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #6  
Old 10-28-2013, 01:30 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
BPD called today and said they bench tested and tested it on a test truck it failed both test. They replaced the power/logic (bottom half) and the test truck started and run fine. They are thinking the blown fuse is another issue. BPD ISN'T going to charge me the $150.00 for the bottom half I just have to pay for shipping.
Reply With Quote Quick reply to this message
  #7  
Old 11-01-2013, 04:11 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I received the ficm back from BPD and installed back on the vehicle
And the truck started right up. I took it for a 30 mile ride and it run just fine.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:50 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors