Please need help with 04 powerstroke... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-07-2013, 07:10 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Please need help with 04 powerstroke...

Hi guys and gals, newbie here....I've been having two problems with my 6.0, first this happens 7 out of 10 times, whenever my truck reaches normal operating temperature, specially when I'm sitting at a traffic light, when the truck starts to move and in between 1100-1450 RPMs it hesitates and bogs for a couple of seconds and then takes off like a bat outta hell. Whenever this happens thru my rearview mirrors I see black smoke coming out of the exhaust pipe, not much but it lasts as long as the hesitation and bogging continues, remembering that this only happens at normal operating temperature (no iddle issues nor cold or hot engine temperature). Second issue is that the oil pressure gauge or switch whenever iddleing drops to 0 and if I give a little rpms it goes back to normal, no dropping when the truck is rolling. Oil pressure sensor has been replaced and it still does the same. Sorry about the long post but I wanted to detail this problems to the best of my knowledge. Other than that the truck is running great. Thanks and any help is greatly appreciated.

Diego.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-07-2013, 07:23 PM
Mod Newbie


 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,726
Thanks: 6
Thanked 114 Times in 107 Posts
Feedback Score: 2 reviews
Is the truck completely stock?
Reply With Quote Quick reply to this message
  #3  
Old 10-07-2013, 07:30 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by dhanna6powerstroke View Post
Is the truck completely stock?
No, it has a 6 inch lift kit, aftermarket exhaust and a cold air intake. Stock tune I believe.

Diego.
Reply With Quote Quick reply to this message
  #4  
Old 10-07-2013, 07:32 PM
Mod Newbie


 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,726
Thanks: 6
Thanked 114 Times in 107 Posts
Feedback Score: 2 reviews
EGR system still in place?
Reply With Quote Quick reply to this message
  #5  
Old 10-07-2013, 07:36 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by dhanna6powerstroke View Post
EGR system still in place?
Yeah still in place. No delete kit yet. I'm still trying to learn about this diesel trucks. Only had it for 5 months. Btw she has 160K miles.

Diego.
Reply With Quote Quick reply to this message
  #6  
Old 10-07-2013, 07:39 PM
Mod Newbie


 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,726
Thanks: 6
Thanked 114 Times in 107 Posts
Feedback Score: 2 reviews
Pull the EGR valve. Sounds like it's sticking open causing your smoke and hesitation issue. Not sure on the oil pressure. It obviously has pressure or it wouldn't run since the injectors are ran off oil pressure. Could have gotten a bad sensor.
Reply With Quote Quick reply to this message
  #7  
Old 10-07-2013, 07:47 PM
Compression Ignition Addict
 

Join Date: May 2013
Location: Modesto
Posts: 3,355
Thanks: 196
Thanked 148 Times in 132 Posts
Feedback Score: 0 reviews
Sounds a little bit like a sticky unison ring in the turbo.
If it's sluggish on the bottom end, blows smoke, then cleans up and takes off, it's acting like a non vg turbo IMO
Sent from a phone that makes calls too!
Reply With Quote Quick reply to this message
  #8  
Old 10-07-2013, 07:50 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by dhanna6powerstroke View Post
Pull the EGR valve. Sounds like it's sticking open causing your smoke and hesitation issue. Not sure on the oil pressure. It obviously has pressure or it wouldn't run since the injectors are ran off oil pressure. Could have gotten a bad sensor.
Great idea, I will pull the EGR off tomorrow and check it out. Gotta do some more research on the low oil pressure light. Thanks.

Diego.
Reply With Quote Quick reply to this message
  #9  
Old 10-07-2013, 07:52 PM
Mod Newbie


 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,726
Thanks: 6
Thanked 114 Times in 107 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Teachagmech View Post
Sounds a little bit like a sticky unison ring in the turbo.
If it's sluggish on the bottom end, blows smoke, then cleans up and takes off, it's acting like a non vg turbo IMO
Sent from a phone that makes calls too!
That is an option too, or could be a combo. Valve is easier to check though
Reply With Quote Quick reply to this message
  #10  
Old 10-07-2013, 07:57 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Teachagmech View Post
Sounds a little bit like a sticky unison ring in the turbo.
If it's sluggish on the bottom end, blows smoke, then cleans up and takes off, it's acting like a non vg turbo IMO
Sent from a phone that makes calls too!
Thanks I will check the EGR tomorrow and will keep this in mind also. A friend of mine had a unison problem, but the only difference was that in his case his truck would do it all the time, either hot or cold temperature.

Diego.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors