Air flow problem - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-16-2013, 01:16 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Air flow problem

Hey guys, this is my first post here but I've been around for a year or so getting myself educated with all the great knowledge on this site. So first off, thanks to you all for all the help you've already given me. I've been able to do all sorts of things on my truck that I would have never before tried to tackle.

I am having a problem though that I just can't figure out. When pulling a grade and usually above 2000 RPM's I get a repetitive sucking sound coming from under the hood right on the driver's side. The truck loses some power and rpm's and then the sucking will stop but is sure to come right back again unless I let up on the throttle. When this happens my MAF reading goes from 135 to 75 or so.

Of course describing sounds with words is difficult but it sounds like she's starving for air kind of like if you try to breathe in through your mouth and block the flow with your tongue and then let just a bit of air in before closing it off again and again.

I recently had to have a new turbo put on. It was after this that the noise started occurring so this is the primary suspect but I'm not sure what could be wrong.

Thanks in advance for any thoughts,

Ryan in AK
__________________

2004 6.0, crew cab, long bed
IPR coolant filter
AFE cold air intake
Blue Spring
Mulchatna is offline  
post #2 of 4 Old 09-16-2013, 02:05 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 62 Times in 58 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You may have sucked a rag or plastic bag into the air filter partialy blocking air flow.
Have actually found that a few times.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #3 of 4 Old 09-16-2013, 02:11 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,244
Thanks: 82
Thanked 489 Times in 473 Posts
Mentioned: 4 Post(s)
Quoted: 257 Post(s)
Garage
Feedback Score: 0 reviews
The turbo installer didn't leave something in the intake did they???? Just a thought since you said it's happening after the turbo install.


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is online now  
post #4 of 4 Old 11-06-2013, 01:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Talking Problem solved

Problem solved thanks to Medic969's thread (link below) where he caught his truck's noise on video. It was exactly the same noise my truck was making. Brand new turbo solved the problem....luckily it was still under warranty.

thoughts to what is making this noise?

2004 6.0, crew cab, long bed
IPR coolant filter
AFE cold air intake
Blue Spring
Mulchatna is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome