04 6.0 issues - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-28-2013, 06:53 PM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04 6.0 issues

Hey everyone, new on the site and looking to see if I can get some help regarding issues on my truck. The truck is a late build 04 f250 6.0 with just an egr delete and powermax turbo. Well, I had finished installing the egr delete and new oil cooler after the egr cooler failed. The truck ran great for a couple weeks until one day it felt like the fuel was cutting out and the truck stalled. It started right back up and I made it a little further up the road till it stalled again. Got the truck home long story short the truck will start but idles rough and stalls. Sometimes it stalls in park at idle sometimes I can take the rpms up and it will stall coming down. The truck will have no starts as it heats up but eventually starts back up. Either way the truck is not drivable. the ficm is putting out 48 volts. I replaced the icp sensor, checked wiring to sensors, cleaned ebp sensor, fuel pressure read 100% on snapon scanner, no codes except for cylinders 2 and 4 glow plug circuit and 1 memory code for the crank position sensor which I assume was a previous fix. The truck has just over 80,000 miles and just started having this issue. Any ideas appreciated sorry for the long intro. Im sure theres other details ill remember as the thread progesses. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-29-2013, 01:52 PM
Compression Ignition Addict
 

Join Date: Dec 2011
Location: Snellville,GA
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
There is no fuel pressure sensor on the 6.0. You have to use the test port on the secondary fuel filter housing to get a reading in PSI. The scanner is probably telling you if the fuel pump in on (100%) or not (0%). If you have not installed a blue fuel pressure spring and changed your fuel filters i would start there. Also check your actual and desired ICP numbers on the scanner and get back to us.
Reply With Quote Quick reply to this message
  #3  
Old 08-29-2013, 05:25 PM
Powerstroke Techie


 

Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,022
Thanks: 80
Thanked 60 Times in 32 Posts
Feedback Score: 13 reviews
Quote:
Originally Posted by 04strokeorbroke View Post
Hey everyone, new on the site and looking to see if I can get some help regarding issues on my truck. The truck is a late build 04 f250 6.0 with just an egr delete and powermax turbo. Well, I had finished installing the egr delete and new oil cooler after the egr cooler failed. The truck ran great for a couple weeks until one day it felt like the fuel was cutting out and the truck stalled. It started right back up and I made it a little further up the road till it stalled again. Got the truck home long story short the truck will start but idles rough and stalls. Sometimes it stalls in park at idle sometimes I can take the rpms up and it will stall coming down. The truck will have no starts as it heats up but eventually starts back up. Either way the truck is not drivable. the ficm is putting out 48 volts. I replaced the icp sensor, checked wiring to sensors, cleaned ebp sensor, fuel pressure read 100% on snapon scanner, no codes except for cylinders 2 and 4 glow plug circuit and 1 memory code for the crank position sensor which I assume was a previous fix. The truck has just over 80,000 miles and just started having this issue. Any ideas appreciated sorry for the long intro. Im sure theres other details ill remember as the thread progesses. Thanks
ipr valve has trash in it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors