6.0 lagging bad! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2013, 08:27 AM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 lagging bad!

03 6.0 turbo lag
I have a 2003 6.0 and have recently started having trouble with laggy response on my throttle. When i start the truck up and take it down the road i can sometimes have my foot up to 75% into the petal before it will decide to take off properly, the truck will be accelerating very slow then out of nowhere take off like a bat out of hell. This is a major problem when i try to cross highways or merge onto a road. Can someone please try to point me to what the problem could be, i would prefer not getting killed by oncoming traffic.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-21-2013, 06:35 PM
Powerstroke.org Rookie
 

Join Date: Nov 2011
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have the same problem sometimes - seems the turbo isn't spooling up, but if I let off for a second then romp on it, it goes. No answer here, but will watch what is said....

David
Reply With Quote Quick reply to this message
  #3  
Old 08-21-2013, 07:54 PM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
your not driving the truck right you need to ease into the stump truck arent like hot rods were you stump and go
Reply With Quote Quick reply to this message
  #4  
Old 08-22-2013, 07:18 AM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's not like I just stomp on it to go. I will drive it regular and it will not go anywhere. I think my turbo is shot, it won't start building boost until I am at about 2500 rpm going like 40. Then it'll take off, chirp my tires are roll coal.
Reply With Quote Quick reply to this message
  #5  
Old 08-22-2013, 08:03 AM
Powerstroke.org Rookie
 

Join Date: Aug 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I had the same problem two weeks ago with my 04. Boost on my gauge was showing a quick increase, but the truck really lagged. Took it to a mechanic. We pulled the turbo. The actuator ring was rusted in place. I mean really rusted. Darn thing would not move. This caused the veins to stay in the closed position. So, we put a new ring and actuator in it, and low and behold, power again.

However, let me say this. At a dead stop, if I stomp on it, the truck takes about a second to start moving, and about 2 seconds until it really starts moving. But then, it just rockets across the intersection. I have to plan for that delay though. Kinda use to it now. It has been like that since day one.
Reply With Quote Quick reply to this message
  #6  
Old 08-22-2013, 08:09 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Delaware
Posts: 1,042
Thanks: 14
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I was going to say you might have a turbo boost leak but if it builds up after a few seconds then it sounds like its the turbo. If you have the OEM it is known to have the variable vanes stick. Could be something major or it might just need a good cleaning. When you get it fixed at least once a week take that truck down a back road and really stomp on her to get that trash cleaned out of the turbo.
Reply With Quote Quick reply to this message
  #7  
Old 08-22-2013, 08:16 AM
I don't know nuttin....

 

Join Date: Jul 2006
Location: Tuttle, OK
Posts: 17,154
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by csingleton6.0 View Post
03 6.0 turbo lag
I have a 2003 6.0 and have recently started having trouble with laggy response on my throttle. When i start the truck up and take it down the road i can sometimes have my foot up to 75% into the petal before it will decide to take off properly, the truck will be accelerating very slow then out of nowhere take off like a bat out of hell. This is a major problem when i try to cross highways or merge onto a road. Can someone please try to point me to what the problem could be, i would prefer not getting killed by oncoming traffic.
Does it smoke the whole time?
Best way to fix this is to flog the hell out of it and work that turbo untill it unsticks. If that doenst work, pull it and clean the turbo real good with a small wire wheel and use antisieze on the ring and viens and put it back together. If any oil rings are leaking, a rebuild parts kit can be bought from Garrett for $50
Reply With Quote Quick reply to this message
  #8  
Old 08-22-2013, 08:23 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Delaware
Posts: 1,042
Thanks: 14
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Clay, I love that pic of Sam Elliott! Lot of truth with that statement
Reply With Quote Quick reply to this message
  #9  
Old 08-22-2013, 07:21 PM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pulled the turbo, it was caked with soot, cleaned it up and the whole internal side that attaches to the exhaust was pitted with rust. The veins look shot and torn up. Looks like I'll have to replace most of this thing.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
6.0 problems, lag, throttle lag, throttle response, turbo 6.0

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:30 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors