Vgt duty cycle messed up/ no whistle. HELP!!! - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-15-2013, 07:21 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Vgt duty cycle messed up/ no whistle. HELP!!!

Ok so I have a 05 6.0. My vgt duty cycle is at 45.0% at idle and drops to about 24% wot. I have an exhaust back pressure circuit low and circuit high codes. So I replaces that with no change. Next I changed the map sensor because these 2 sensors tell the computer the vein position (thought mabe that would help). Still no change. Cleans the unison ring and veins last night, put a new vgt solenoid in and also the plug. No change. Wtf. I have a powermax in this and only pushing 28psi with a 100 horse tune in the edge. Does anyone have ideas.
Damian886 is offline  
post #2 of 5 Old 09-21-2013, 08:08 AM
Member
 
Join Date: Dec 2009
Location: North Mississippi
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same problem...you figure out what it was?
7.3ghost is offline  
post #3 of 5 Old 02-08-2015, 02:03 PM
Member
 
Join Date: May 2013
Location: cleveland
Posts: 76
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 1 reviews
same problem now did anyone figure it out lol

2005 F350 ccsb way to many things to list
mderrickson216 is offline  
post #4 of 5 Old 02-08-2015, 03:34 PM
Compression Ignition Addict
 
05KRPSD's Avatar
 
Join Date: Dec 2013
Posts: 585
Thanks: 30
Thanked 25 Times in 24 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Did you clean or replace your ebp sensor? Did you clean the tube going to the sensor?


John
2005 F350 King Ranch
AFE cold air intake
Magnaflow 4in turbo back
Swamps 58v ficm(Never sees 58v)
Diesel Site coolant filter/ELC coolant
Egr delete
Blue spring mod
B&W Gooseneck hitch/Companion Fifth Wheel
05KRPSD is offline  
post #5 of 5 Old 02-09-2015, 03:27 AM
Member
 
Join Date: May 2013
Location: cleveland
Posts: 76
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 1 reviews
yeah it was clogged cleared it up a little but doing that cleaning map nipple replaced tube cleaned turbo ordered a new ebp sensor cleaned vgt solonoid gonna pull the ait out and clean it today also gets better little by little egt wise but still no whistle until high idle also running a powermax and only 28psi a wot with a gearhead extreme tune

2005 F350 ccsb way to many things to list
mderrickson216 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome