turbo problem - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 05-10-2008, 07:30 PM Thread Starter
Powerstroke.org Fanatic
 
matt081288's Avatar
 
Join Date: Oct 2007
Location: Macon, GA
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Exclamation turbo problem

Hey guys i have an early 04 crew cab f250. I just installed a turbo back magnaflow exhaust system two days ago and after the truck ran for a few minutes i took off down the road. While going down the road the truck started to sputter and act crazy. It acted like the turbo would shut down and start back up. You can hear it whistle and then it would stop and start again. The truck jerks when this happens and loses power. This has never happened before and just started with the new exhaust. It will do it sometimes and sometimes it wont. Any help would be greatyl appreciated.


2008 Ford F250 CC Lariat
-H&S Mini Maxx
-S&B Cold Air Intake
-4" Flo Pro DP back (no muffler)
-Flo Pro EGR Delete Kit
-2 inch leveling spacers
-35x12.50-20 Nitto Trail Grapplers

BuIlT fOrD tOuGh
matt081288 is offline  
post #2 of 18 Old 05-10-2008, 09:33 PM
Compression Ignition Addict
 
BryanH's Avatar
 
Join Date: Nov 2007
Location: San Antonio
Posts: 3,196
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by matt081288 View Post
Hey guys i have an early 04 crew cab f250. I just installed a turbo back magnaflow exhaust system two days ago and after the truck ran for a few minutes i took off down the road. While going down the road the truck started to sputter and act crazy. It acted like the turbo would shut down and start back up. You can hear it whistle and then it would stop and start again. The truck jerks when this happens and loses power. This has never happened before and just started with the new exhaust. It will do it sometimes and sometimes it wont. Any help would be greatyl appreciated.
It is poss/ that this is not a result of the new exhaust. Just a problem surfaced at the sametime you installed your pipe. I am going to watch this thread, Sorry I could not help, But I am sure someone will be along shortly.

Good luck man.

546K 7.3L Hauler>>
Central Texas Hotshots
BryanH is offline  
post #3 of 18 Old 05-10-2008, 09:35 PM
Compression Ignition Addict
 
BryanH's Avatar
 
Join Date: Nov 2007
Location: San Antonio
Posts: 3,196
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
How fast are the power losses, Is it like 2-3 seconds when you are driving, Or is it long like a minute or two?

546K 7.3L Hauler>>
Central Texas Hotshots
BryanH is offline  
post #4 of 18 Old 05-11-2008, 07:36 AM Thread Starter
Powerstroke.org Fanatic
 
matt081288's Avatar
 
Join Date: Oct 2007
Location: Macon, GA
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
The it just sounds like a turbo fart while you are in the throttle and it only does it for a second or so but when it does it it will get power loss it gets it and lose it. It doesn't do it all the time sometimes it runs fine and sometimes it goes crazy. I thought it might have been my programmer but i put it back to stock and that didnt help. Do you think it might be the result of an exhaust leak or anything? I mean this sucks. LOL


2008 Ford F250 CC Lariat
-H&S Mini Maxx
-S&B Cold Air Intake
-4" Flo Pro DP back (no muffler)
-Flo Pro EGR Delete Kit
-2 inch leveling spacers
-35x12.50-20 Nitto Trail Grapplers

BuIlT fOrD tOuGh
matt081288 is offline  
post #5 of 18 Old 05-11-2008, 08:01 AM
Compression Ignition Addict
 
mountainlander's Avatar
 
Join Date: Mar 2007
Location: Arlington, TX
Posts: 798
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds too extreme to be an exhaust leak to me.

Did you knock the plug off the turbo messing with the downpipe?

Also is it throwing any codes?

Robert Fenton

'Bessie' --2004 Excursion Limited 4x4 6.0L --SOLD with a blown head gasket, Bad EGR Valve and Cooler, Bad oil cooler

And then there was one:
4" Turbo Back from Gus @ Farmboy Diesel --in garage waiting to be installed--FOR SALE

Support our boys through AmericanSnipers.org
mountainlander is offline  
post #6 of 18 Old 05-11-2008, 08:07 AM
Compression Ignition Addict
 
BryanH's Avatar
 
Join Date: Nov 2007
Location: San Antonio
Posts: 3,196
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
[QUOTE=mountainlander;580708]Sounds too extreme to be an exhaust leak to me.

Did you knock the plug off the turbo messing with the downpipe?

Also is it throwing any codes?[/QUOTE

Good thinking, Review your work, See if anything is out of place, Did you clean the egr valve?

546K 7.3L Hauler>>
Central Texas Hotshots
BryanH is offline  
post #7 of 18 Old 05-11-2008, 08:37 AM Thread Starter
Powerstroke.org Fanatic
 
matt081288's Avatar
 
Join Date: Oct 2007
Location: Macon, GA
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
the truck isnt throwing any codes... and what plug are you guys talking about where is it located and how do you check the egr valve? thanks for yalls help all i can figure is i might have knocked something lose or something came unplugged when i installed/removed the downpipe. Tell me what to look for and i will check i dont know where to locate the plug. or the egr valve


2008 Ford F250 CC Lariat
-H&S Mini Maxx
-S&B Cold Air Intake
-4" Flo Pro DP back (no muffler)
-Flo Pro EGR Delete Kit
-2 inch leveling spacers
-35x12.50-20 Nitto Trail Grapplers

BuIlT fOrD tOuGh
matt081288 is offline  
post #8 of 18 Old 05-11-2008, 08:45 AM
DKR
<--Pro Cooler Racer
 
DKR's Avatar
 
Join Date: Dec 2006
Location: Newark, Delaware
Posts: 8,216
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Skype™ to DKR
Just check around the turbo and make sure there is nothing loose or disconnected. If nothing obvisous, then pull the intake tube and check the inlet shaft for play or damaged fins. If nothing still, you might have to pull the turbo and check the exhaust vanes.

Unless you knocked something off doing the install, I doubt the problem was caued by the exhaust install.

Eric
2007 F250 6.0l King Ranch CC LB
Sponsored by Innovative Diesel Performance
SCT XCal2 w/ Custom Files & FICM tuning
DashDAQ Series II; ARP Headstuds; AFE Stage 2 XP Intake w/ Proguard 7
Industrial Injection 190cc injectors; FASS 150/180; ITP Regulated Return
'03 Turbo Swap; Zex N2O Dry Shot; CFM Smallmouth Intake Elbow
Zoodad w/ Predator Screen; MBRP 4" Cool Duals Straight Piped
EGR Delete w/ full manifold; Coolant Bypass Filter; Train Horns
Eclipse AVN62D; High Idle Mod; BFG ATs 285-65/20s

Truck- 12.51sec @ 108mph @ ~7700lbs (1/4 mi)
Cooler- 39.93sec @ 12.12mph @ ~180lbs (1/8 mi)

Email: DKR@powerstroke.org
DKR is offline  
post #9 of 18 Old 05-11-2008, 09:44 AM Thread Starter
Powerstroke.org Fanatic
 
matt081288's Avatar
 
Join Date: Oct 2007
Location: Macon, GA
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
ok i think i found the problem... apparently when i lowered the transmission it pulled the intake tube off of the front of the turbo... i guess it wasnt getting enough air... it had an extremely loud whistle but now that i have replaced the tube the whistle has died dound tremendoously and everything is working fine... could this have been my problem?


2008 Ford F250 CC Lariat
-H&S Mini Maxx
-S&B Cold Air Intake
-4" Flo Pro DP back (no muffler)
-Flo Pro EGR Delete Kit
-2 inch leveling spacers
-35x12.50-20 Nitto Trail Grapplers

BuIlT fOrD tOuGh
matt081288 is offline  
post #10 of 18 Old 05-11-2008, 11:21 AM
Compression Ignition Addict
 
mountainlander's Avatar
 
Join Date: Mar 2007
Location: Arlington, TX
Posts: 798
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds reasonable to me.

Robert Fenton

'Bessie' --2004 Excursion Limited 4x4 6.0L --SOLD with a blown head gasket, Bad EGR Valve and Cooler, Bad oil cooler

And then there was one:
4" Turbo Back from Gus @ Farmboy Diesel --in garage waiting to be installed--FOR SALE

Support our boys through AmericanSnipers.org
mountainlander is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome