Low Power - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-11-2013, 08:42 PM Thread Starter
Member
 
elund126's Avatar
 
Join Date: Mar 2012
Location: Bonney Lake, WA
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Low Power

Long time lurker here. I apologize in advance for the long post. I seriously have spent probably 10 hours reading posts on this forum. I have a 2007 F250. It is bone stock with 60K miles. It has ran perfect since I bought it about 15 months ago with 49K miles. I do the regular maintenance including fuel filters (about 9K ago). About 1 time a month in the spring/summer, we tow a 27 foot travel trailer. I have an Edge Insight CS hooked up and ECT/EOT is all normal. FICM is spot on and so is everything else I have learned by searching and reading posts.

Just recently in the last month, it seems to have lost power from a stop. Once it hits 2K RPM's, it is OK. I cleaned out the EGR twice. The first time it was pretty dirty. VGT has been hanging at 85% at idle and then varied between 40-60 while driving. Mind you, I was at work and trying to get my wife to read various gauges while she was driving.

Tonight, I pulled the EBP tube and it was semi clogged. I sprayed it out and cleaned all the gunk out of it and re-installed it.

Here are the things that I can't figure out if they are normal.

- EBP is at 0 with KOEO (MAP and BARO are around 14). EBP I think went up to 40 on WOT run.
- VGT at idle is around 72-76% Wide open throttle only goes down to 40%. I never saw anything below 40%
- The only DTC I threw was a p0299 (low boost).

In my mind I think my turbo needs to be cleaned and/or my catalytic converter is plugged. (I don't know if the EBP numbers can help diagnose the cat)

This post is at the end of a 12 hour work day and 2 hours of tinkering with the truck. I might be forgetting something.

If anyone has any questions, suggestions, or answers, I would very greatly appreciate any help or advice!!
elund126 is offline  
post #2 of 5 Old 08-12-2013, 05:09 AM
Premium Member

 
twoicebergs's Avatar
 
Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,425
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 8
Thanked 125 Times in 117 Posts
Feedback Score: 0 reviews
Quote:
- EBP is at 0 with KOEO (MAP and BARO are around 14). EBP I think went up to 40 on WOT run.
- VGT at idle is around 72-76% Wide open throttle only goes down to 40%. I never saw anything below 40%
- The only DTC I threw was a p0299 (low boost).
Since you get normal results above 2000 RPM (?), you may not be dealing with a major issue. Possibly your turbo is not sealed correctly, your vanes are not working properly or more than likely you have a crack on a boot or on the tube to the MAP sensor. The low boost DTC is telling your story of low power. That code needs a few seconds to set, so you need to find the leak or figure out why the turbo is not pumping properly. Other than that, your EBP is somewhat normal if the reading is relative pressure. The VGT seems OK depending on the tune, but often at long WOT running the VGT opens wide or at least to 25% (again depending on tune). I doubt you CAT is plugged, your EGTs would be very high, assuming you could monitor it.

Frank
2007 F-250 Lariat Crew. MBM 190/50s,
KC-68 Stage 3 Turbo,
DashBoss/F/P, and a few other goodies
Stiction Problems - Fix it yourself! - http://www.powerstroke.org/forum/gen...ml#post4509754
Want to modify your injectors DIY - http://www.powerstroke.org/forum/6-0...ger-flows.html

Working for Toys
twoicebergs is offline  
post #3 of 5 Old 08-13-2013, 06:32 PM Thread Starter
Member
 
elund126's Avatar
 
Join Date: Mar 2012
Location: Bonney Lake, WA
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Thanks for the reply. I have the next 4 days off, so I am going to check all the turbo connections and. I don't have a tune, so it sounds like VGT is ok then.



2007 F-250 Crew Cab Long Bed Lariat 4x4
Stock 6.0
Edge Insight CS
DC Power Alt.
Window Tint
Kenwood DDX419 Touch Screen CD, DVD, Bluetooth
Sound Ordinance 8" sub/amp

elund126 is offline  
post #4 of 5 Old 07-25-2014, 09:02 AM
Powerstroke.org Fanatic
 
chris-rector's Avatar
 
Join Date: Oct 2010
Location: Centennial CO
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
So what ended up being the problem with the low power sounds just like what mine just started doing

<a href="http://truckprofile.com/members/chris-rector/Ford-F350-2003/694">My Truck Profile</a>
chris-rector is offline  
post #5 of 5 Old 07-27-2014, 10:00 AM Thread Starter
Member
 
elund126's Avatar
 
Join Date: Mar 2012
Location: Bonney Lake, WA
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
06 F250- EBP Cleaning

Check out this post. I cleaned my EBP tube and sensor and it helped alot. Although now I think my CAC boots are worn out and need replacing. I am getting intermittant hesitation in acceleration from a stop.



2007 F-250 Crew Cab Long Bed Lariat 4x4
Stock 6.0
Edge Insight CS
DC Power Alt.
Window Tint
Kenwood DDX419 Touch Screen CD, DVD, Bluetooth
Sound Ordinance 8" sub/amp

elund126 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome