6.0 lost power please help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-03-2013, 03:07 PM Thread Starter
Powerstroke.org Rookie
Join Date: May 2010
Location: Hoffman Estates
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 lost power please help

Was driving done the interstate hammering on it all of a sudden lost all power after a whoosh of air. Now no turbo pressure at all on dash or monitor. Checked turbo pipes for breeches in blue coupling could not find none.
Now truck only runs 50mph EGT's hit 1350 blowing thick black smoke enough to obscure vision for people behind me.
2005powerstroke is offline  
Sponsored Links
post #2 of 2 Old 08-03-2013, 03:45 PM
Mod Newbie

dhanna6powerstroke's Avatar
Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 13,111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 139 Times in 132 Posts
Feedback Score: 2 reviews
You blew a boot off. Did look at the one on the drivers side at the bottom? Hard to see without removing air filter

dhanna6powerstroke is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome