HP!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-03-2013, 02:42 PM Thread Starter
Compression Ignition Addict
Join Date: Jul 2013
Posts: 936
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 3
Thanked 12 Times in 11 Posts
Feedback Score: 0 reviews

I have been driving a lot this summer with my 04 6.0, and was noticing that i feel like im losing ponies every minute, at first i thought it might be where im driving a lot more and getting really used to it, but it seems like im not pushing as much boost as i used to, and my turbo dies down slower than it used to, idk, but what could make it lose power, id really like to know before it messes up worse and i end up breaking the piggy bank open.
mySIXOisSick is offline  
Sponsored Links

6.0, boost, ficm, heads, losing power

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome