6.0 problems need help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-23-2013, 09:25 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 problems need help

I've recently bought a 6.0 and I've had it for a about a year put 50,000 miles on it with no problems the other day I noticed it smoking alot when you would let off of it and get back in it. Then it quit, starting noticing a lot of lost power then the other day started running really rough and at 55-60 runs absolutely horrible when you rev it up on the deceleration it makes a horrible bang. Then it seems to run ok for 30 seconds or so at idle and then rough again at idle the turbo Dosent seen to spool up and if it dose it's super choppy people are telling me it's my turbo or my icp sensor but I don't wanna blow 1200 on a new turbo if my icp sensor is out someone please help me thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-23-2013, 09:26 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also isnt throwing codes
Reply With Quote Quick reply to this message
  #3  
Old 07-23-2013, 09:41 PM
KCCO!!

 

Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
1. Welcome to the org! 2. What kind of mods do you have if any?
Reply With Quote Quick reply to this message
  #4  
Old 07-23-2013, 09:57 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ficm is what my budy found out bout my truck. Same problems
Reply With Quote Quick reply to this message
  #5  
Old 07-23-2013, 10:06 PM
KCCO!!

 

Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
That was my first guess, do you have a monitor, if so, what's your numbers for your FICM?
Reply With Quote Quick reply to this message
  #6  
Old 07-23-2013, 10:08 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine showed good on monitor but when taken off i guss it showed bad

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #7  
Old 07-23-2013, 10:10 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Kelly i just found this out 3 hrs ago, sending it off in morning to have it rebuilt. My question is whats better 58v or 48v

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #8  
Old 07-24-2013, 03:00 AM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by kells17 View Post
1. Welcome to the org! 2. What kind of mods do you have if any?
It has a blue spring a 4" from the turbo back stright piped an egr delete and I have a bully dog power pup programmer but I don't have a monitor or gauges I now I need them really bad just haven't got around to it
Reply With Quote Quick reply to this message
  #9  
Old 07-27-2013, 10:46 PM
KCCO!!

 

Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by powerstroke61764 View Post
Kelly i just found this out 3 hrs ago, sending it off in morning to have it rebuilt. My question is whats better 58v or 48v

Sent from AutoGuide.com Free App
Personal preference on if you want to keep it "stock" or tuned. Most get a tune put on it. Regardless what tune you get, if you have an INSIGHT, it will not show more than 50V (someone correct me if I'm wrong). So if you decide to go 58V, don't be in dismay to see it not "reading" 58V.
Reply With Quote Quick reply to this message
  #10  
Old 07-27-2013, 10:46 PM
KCCO!!

 

Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Powerstrokin321 View Post
It has a blue spring a 4" from the turbo back stright piped an egr delete and I have a bully dog power pup programmer but I don't have a monitor or gauges I now I need them really bad just haven't got around to it
Any news bud?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors