NEED HELP - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-07-2013, 06:00 AM Thread Starter
Powerstroke.org Rookie
 
pillsbury's Avatar
 
Join Date: Jun 2009
Location: Hicksboro NC
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
NEED HELP

I pulled out to pass a semi truck the other day on the interstate. When I got on the gas and the turbo spooled up instead of the truck taking off it started making a hissing sound. It sounds like that air blowing out of a air compressor. It only does it under a load. I put a load on it and got to listening to it. I comes form the air breather. Any ideas? I pulled the breather off the turbo and the fins have a little play in it. Thanks in advanced for all the help.

gary


mbrp 5" turbo back stright piped exhaust 6" tip
airaid cold air intake
ARP Head Studs
superchip
pillsbury is offline  
post #2 of 7 Old 07-07-2013, 06:06 AM
KCCO!!
 
kells17's Avatar
 
Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Did you still have power for the pass or did you lose boost psi? Could be exhaust leak in y-pipe?

2004 F-250 Lariat CCSB

Studded, Deleted, Cold Air, Fog Light Mod,
IPR HF Coolant Filter, High Idle, Atlas 40 FICM,
CCV, Edge Insight CTS, ZooDad, BPD Oil Cooler,
4" Banks Monster Exhaust, Fumotos, 05 Harley Headlights,
Blue Spring, Kill Switch, 03 Turbo and 6.4 Banjo Bolts

VA Strokers
757 Diesel

kells17 is offline  
post #3 of 7 Old 07-07-2013, 06:20 AM Thread Starter
Powerstroke.org Rookie
 
pillsbury's Avatar
 
Join Date: Jun 2009
Location: Hicksboro NC
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Had some power, but not like it should.


mbrp 5" turbo back stright piped exhaust 6" tip
airaid cold air intake
ARP Head Studs
superchip
pillsbury is offline  
post #4 of 7 Old 07-07-2013, 06:52 AM
KCCO!!
 
kells17's Avatar
 
Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I would check the y-pipe first...see if there is soot back there on the firewall. If all is clear there, check turbo intake tube...if you still have the OEM silicon (sleeves) on your intake...very well could be one of those has split...

2004 F-250 Lariat CCSB

Studded, Deleted, Cold Air, Fog Light Mod,
IPR HF Coolant Filter, High Idle, Atlas 40 FICM,
CCV, Edge Insight CTS, ZooDad, BPD Oil Cooler,
4" Banks Monster Exhaust, Fumotos, 05 Harley Headlights,
Blue Spring, Kill Switch, 03 Turbo and 6.4 Banjo Bolts

VA Strokers
757 Diesel

kells17 is offline  
post #5 of 7 Old 07-07-2013, 03:58 PM Thread Starter
Powerstroke.org Rookie
 
pillsbury's Avatar
 
Join Date: Jun 2009
Location: Hicksboro NC
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I will check that. Now my power steering is acting up. No low speed I have no power steering. Not sure if they are related or not


mbrp 5" turbo back stright piped exhaust 6" tip
airaid cold air intake
ARP Head Studs
superchip
pillsbury is offline  
post #6 of 7 Old 07-07-2013, 04:47 PM
Premium Member

 
tkobes43's Avatar
 
Join Date: Jan 2011
Location: Sussex NJ
Posts: 1,717
Thanks: 13
Thanked 15 Times in 15 Posts
Mentioned: 1 Post(s)
Quoted: 2 Post(s)
Garage
Feedback Score: 0 reviews
Check intercooler boots!! I had the same issue and my lower intercooler boot was loose. Tightened it back up and i had all my boost back.


Tom

5" MBRP Straight Exhaust w/ 6" tip, SCT Monitored, Limo Tints, 20" LED Lightbar, 8k HIDS, & Some other goodies
Other Rides
1978 Trans Am Y88 403 84k original miles
1996 Ford F350 PSD Mason Dump 134k Original Miles!
Gone But Not Forgotten... (Lilah) 2008 Ford F250 Lariat CrewCab
Proud To Be An American!
tkobes43 is offline  
post #7 of 7 Old 07-07-2013, 04:49 PM
Premium Member
 
MyTractorsSexy's Avatar
 
Join Date: Sep 2011
Location: St.Louis Mo
Posts: 1,614
Thanks: 1
Thanked 9 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 2 reviews
or it could be a cracked boot it may be loose or cracked. or there is a crack in the y pipe flex pipe area


07 F250 Lariat ECSB bed FX4 6.0
leveling kit, DDM HID's
XD Strike 17x9 -24 offset 295/70/17 Hankook ATm
fox shocks & fox dual steering stabilizer kit
4in. straight pipe, Riff Raff boots, Beans sump
ARP's, Tuned, Deleted
coolant filter, bluespring, CAI
6.4 Banjo Bolts, BPD FICM
Alpine Head unit, 4 Hertz 140W door speakers, 2 rockford fosgate 10's, kenwood amps.

More pics in profile.
MyTractorsSexy is offline  
Reply

Tags
no power , turbo 6.0

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome