NEED HELP - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-07-2013, 06:00 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Hicksboro NC
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
NEED HELP

I pulled out to pass a semi truck the other day on the interstate. When I got on the gas and the turbo spooled up instead of the truck taking off it started making a hissing sound. It sounds like that air blowing out of a air compressor. It only does it under a load. I put a load on it and got to listening to it. I comes form the air breather. Any ideas? I pulled the breather off the turbo and the fins have a little play in it. Thanks in advanced for all the help.

gary
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-07-2013, 06:06 AM
KCCO!!

 

Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Did you still have power for the pass or did you lose boost psi? Could be exhaust leak in y-pipe?
Reply With Quote Quick reply to this message
  #3  
Old 07-07-2013, 06:20 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Hicksboro NC
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had some power, but not like it should.
Reply With Quote Quick reply to this message
  #4  
Old 07-07-2013, 06:52 AM
KCCO!!

 

Join Date: Jan 2013
Location: Virginia Beach
Posts: 301
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I would check the y-pipe first...see if there is soot back there on the firewall. If all is clear there, check turbo intake tube...if you still have the OEM silicon (sleeves) on your intake...very well could be one of those has split...
Reply With Quote Quick reply to this message
  #5  
Old 07-07-2013, 03:58 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Hicksboro NC
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will check that. Now my power steering is acting up. No low speed I have no power steering. Not sure if they are related or not
Reply With Quote Quick reply to this message
  #6  
Old 07-07-2013, 04:47 PM
Premium Member
 

Join Date: Jan 2011
Location: Sussex NJ
Posts: 1,518
Thanks: 2
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Check intercooler boots!! I had the same issue and my lower intercooler boot was loose. Tightened it back up and i had all my boost back.


Tom
Reply With Quote Quick reply to this message
  #7  
Old 07-07-2013, 04:49 PM
Premium Member
 

Join Date: Sep 2011
Location: St.Louis Mo
Posts: 1,567
Thanks: 1
Thanked 6 Times in 6 Posts
Feedback Score: 2 reviews
or it could be a cracked boot it may be loose or cracked. or there is a crack in the y pipe flex pipe area
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
no power, turbo 6.0

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors