2005 F250 left turn signal and brake light now working. - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-03-2013, 06:03 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2012
Location: North Georgia
Posts: 124
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2005 F250 left turn signal and brake light now working.

Please don't yell at me. I promise I searched first for my answer but couldn't find a match. Just bought a 2005 F250 and the guy said the turn signal stopped working on the way home the day before. I drove the truck when it was working so I believe him. Thought it was just a bulb because it is blinking fast. Bulb is good and I even swapped the socket for the right on. Still nothing. Outside of a broken wire, anyone had this happen? I called myself checking the fuses and they all look good. Haven't been able to check much else due to rain so I thought I would check here. Thanks.
seeemmiss is offline  
post #2 of 5 Old 07-03-2013, 11:58 PM
Compression Ignition Addict

 
RollinEarly99's Avatar
 
Join Date: May 2008
Location: Klamath Falls
Posts: 3,381
Thanks: 30
Thanked 25 Times in 24 Posts
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Feedback Score: 10 reviews
Quote:
Originally Posted by seeemmiss View Post
Please don't yell at me.:
lol, sounds like a wire shorting out. Are the trailer lights doing the same thing on that side?

05 F-250 Crew Cab Short Bed
ARPs w/OEM Gaskets
MTW Stage 2 w/batmowheel
BPD oil cooler w/ cold weather package
BPD Updated umm...Everything
BPD bypass oil filter
BPD FICM 58v
Spring Mod
Egr deleted
4" Duals
Edge CTS
Custom grille made by Me
X3 w/Matts SRL+/SRLxx and Tow Tunes
Tony WildmanExtreme w/early lockup



RollinEarly99 is offline  
post #3 of 5 Old 07-05-2013, 05:47 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2012
Location: North Georgia
Posts: 124
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I haven't checked a trailer yet but i will when I get home. Thanks
seeemmiss is offline  
post #4 of 5 Old 11-18-2013, 01:23 PM
Compression Ignition Addict
 
jtaylor75's Avatar
 
Join Date: Dec 2011
Location: Snellville,GA
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
mine is doing the exact same thing. Have you found out what it is yet?

06 CCSB FX4 Lariat

Studded and Deleted, Warren 190/100s, Barder Stage 4, Built Trans, AIS Water/Meth, S&B intake, 4 inch Exhaust

Next:
A fuel system
jtaylor75 is offline  
post #5 of 5 Old 11-19-2013, 01:19 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2012
Location: North Georgia
Posts: 124
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yep. It was a wife pulled out of the factory plug. The entire pin was pled free from the plug some how. On e I traced it to the plug, it was easy. Good luck and hope this helps.

2005 F250 CCSB 4x4
Yep. It has studs.
seeemmiss is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome