2005 F250 left turn signal and brake light now working. - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-03-2013, 06:03 PM
Member
 

Join Date: Jun 2012
Location: North Georgia
Posts: 85
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 F250 left turn signal and brake light now working.

Please don't yell at me. I promise I searched first for my answer but couldn't find a match. Just bought a 2005 F250 and the guy said the turn signal stopped working on the way home the day before. I drove the truck when it was working so I believe him. Thought it was just a bulb because it is blinking fast. Bulb is good and I even swapped the socket for the right on. Still nothing. Outside of a broken wire, anyone had this happen? I called myself checking the fuses and they all look good. Haven't been able to check much else due to rain so I thought I would check here. Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-03-2013, 11:58 PM
RollinEarly05...now

 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,250
Thanks: 22
Thanked 20 Times in 19 Posts
Feedback Score: 8 reviews
Quote:
Originally Posted by seeemmiss View Post
Please don't yell at me.:
lol, sounds like a wire shorting out. Are the trailer lights doing the same thing on that side?
Reply With Quote Quick reply to this message
  #3  
Old 07-05-2013, 05:47 AM
Member
 

Join Date: Jun 2012
Location: North Georgia
Posts: 85
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I haven't checked a trailer yet but i will when I get home. Thanks
Reply With Quote Quick reply to this message
  #4  
Old 11-18-2013, 01:23 PM
Compression Ignition Addict
 

Join Date: Dec 2011
Location: Snellville,GA
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine is doing the exact same thing. Have you found out what it is yet?
Reply With Quote Quick reply to this message
  #5  
Old 11-19-2013, 01:19 PM
Member
 

Join Date: Jun 2012
Location: North Georgia
Posts: 85
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yep. It was a wife pulled out of the factory plug. The entire pin was pled free from the plug some how. On e I traced it to the plug, it was easy. Good luck and hope this helps.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:23 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors