2004 6.0 shuts down while driving - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-27-2013, 01:12 PM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2004 6.0 shuts down while driving

the truck shuts down while driving but starts back up fine. it does it at random lengths of driving. the batteries, alternator, and starter are fine. also got a new fuel pump 2 months ago. any suggestions would be nice.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-27-2013, 02:06 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine does the same thing.. you have any luck finding out why? mine broke today was getting fuel idling fine while getting fuel as i always do turned out onto road to red light sitting there at idle stalled started back up idled for minute and dies... so im stuck on this too...
Reply With Quote Quick reply to this message
  #3  
Old 06-27-2013, 03:41 PM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cope102 took it to a mechanic today and he found out it was the wiring harness by the ficm. every time he pulled on it truck shut right off. hope that helps
Reply With Quote Quick reply to this message
  #4  
Old 06-28-2013, 08:42 PM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 182
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Brister View Post
the truck shuts down while driving but starts back up fine. it does it at random lengths of driving. the batteries, alternator, and starter are fine. also got a new fuel pump 2 months ago. any suggestions would be nice.


most of the time when a truck does this.i have found itr to be the magnetics in thew ipr bad.put a new one in and should be fine.
Reply With Quote Quick reply to this message
  #5  
Old 07-01-2013, 11:03 AM
Member
 

Join Date: Jun 2009
Location: BHC
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine was wiring harness, they are very proud of them. SRP $800+, purchased from a well known dealer in Minnesota. I think just under $500 shipped. Good luck.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors