turbo spooling but truck not goin anywhere! help!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 29 Old 06-16-2013, 10:11 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Breaux Bridge
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
turbo spooling but truck not goin anywhere! help!!

so, i have this issue with the truck. i kinda dont understand what it is.

ill start the truck, let it warm up go for a ride . ill get on it a bit the turbo will spool up and i can feel the power. now heres where it gets weird. when the truck gets hot, it will loose power. u can still here the turbo spooling, but u have to damn nea put the pedal to the flooor then u can count 1,2,3 then u can feel it get power but the exhaust just roars but the truck doesnt go anywhere. it only does that after its warmed up. then when i get to 50 mph im guessin it goes into overdrive cause the rpm will drop and itll just cruise but to actually get up and go, i have to push the pedel to the floor. and the weird part is, after its warmed up from a dead stop i can kindsa get on it and it will go a bit but one i get to second or third here i try to get on it..all u can hear is spooling and building boost but not goin anywhere. the highest i could get boost to was about 12-15 pounds and i know it can twice that much. could it just be dirty turbo? please help

03 f350
ARP Studs
Coolant Filter
DC Power inc Alt.
FICM with Reflash
Edge Juice
EGR Delete
Oil Cooler
Fuel Press,EOT,ECT Gauges
40 Inch Toyos
10 inch lift
Straight 4" back with 7" Mbrp tip
LAredneck6.0 is offline  
Sponsored Links
Advertisement
 
post #2 of 29 Old 06-16-2013, 10:24 PM
Serving Our Country!
 
JustinOOO9's Avatar
 
Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,896
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 80
Thanked 94 Times in 59 Posts
Feedback Score: 0 reviews
how long have you been running the bigger tires it could be trans related as well... you have a guage to monitor "torque converter lock up %) and shifts?

2004 F350 CCLB 4x4: Sinister Race solutions kit, CAT ELC Edge CS, SCT SF3, PHP Ficm programmer, Procomp, Rough country, and Nitto goodies. SOLD

Interested in learning something new?

http://www.powerstroke.org/forum/pol...verse-day.html


Justin,
JustinOOO9 is offline  
post #3 of 29 Old 06-16-2013, 10:37 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Breaux Bridge
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
a good while... and no i dont have gauge to monitor it. it shifts when its supposed to . i was hoping maybe veins sticking in the turbo. cause its done this before but to an extent. how could i tell if it was trans related or torque converter related?

03 f350
ARP Studs
Coolant Filter
DC Power inc Alt.
FICM with Reflash
Edge Juice
EGR Delete
Oil Cooler
Fuel Press,EOT,ECT Gauges
40 Inch Toyos
10 inch lift
Straight 4" back with 7" Mbrp tip
LAredneck6.0 is offline  
post #4 of 29 Old 06-17-2013, 05:49 AM
Premium Member

 
twoicebergs's Avatar
 
Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,389
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 8
Thanked 123 Times in 115 Posts
Feedback Score: 0 reviews
Without it being an exhaust or boost leak, the most probable cause is a fouled VGT section in the turbo. The way you described it, it could also be a transmission or T/C problem. If it was slipping a lot there is only a small load, so you wouldn't get high boost at all. However, without a monitor and diagnosis, who really knows. Get a monitor and save yourself and us from the aggravation of guessing.

Frank
2007 F-250 Lariat Crew. MBM 190/50s,
KC-68 Stage 3 Turbo,
DashBoss/F/P, and a few other goodies
Stiction Problems - Fix it yourself! - http://www.powerstroke.org/forum/gen...ml#post4509754
Want to modify your injectors DIY - http://www.powerstroke.org/forum/6-0...ger-flows.html

Working for Toys
twoicebergs is offline  
post #5 of 29 Old 07-14-2013, 03:04 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Breaux Bridge
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
K well I did a VGT relearn and nothin. Same thing. Its gotten worse. Like it boggs down. I have to floor it for it to go. Fo I have to unplug programmer to do the vgt relearn or just put it in stock mode? Also. Doesn't feel slippage on trans. Ill floor it anf rpms will go up to about 3000 rpm and boost will only go up to about 15 pounds when I know its capable of more. Where should I start for exhaust or boost leaks. I do have a few plugs just hanging around. Cause I put new intake elbow from sinister and egr delete also.

03 f350
ARP Studs
Coolant Filter
DC Power inc Alt.
FICM with Reflash
Edge Juice
EGR Delete
Oil Cooler
Fuel Press,EOT,ECT Gauges
40 Inch Toyos
10 inch lift
Straight 4" back with 7" Mbrp tip
LAredneck6.0 is offline  
post #6 of 29 Old 07-14-2013, 03:09 PM
Premium Member
 
Join Date: Apr 2011
Location: Baton Rouge
Posts: 1,127
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Sounds like a boost leak to me. Are your egts higher than normal also?
Moto2four is offline  
post #7 of 29 Old 07-14-2013, 03:13 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Breaux Bridge
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea. Normal there wothin 15 degrees or so. Ill notice when im having to get on it it will go up to about 220. Or so. When truck is fully hot it runs more and more sluggish like my pedal feels like I have no power. And im running 65 pounds of fuel psi at idle and as low as 55-57 at WOT. It spools up slow I feel boosting up feels like the its boost and boost is dissapearing. Lol. And I have brand new oil cooler and coolant filter and new oil change. Truck is running hot from no good boost. Where could boost leak be

03 f350
ARP Studs
Coolant Filter
DC Power inc Alt.
FICM with Reflash
Edge Juice
EGR Delete
Oil Cooler
Fuel Press,EOT,ECT Gauges
40 Inch Toyos
10 inch lift
Straight 4" back with 7" Mbrp tip
LAredneck6.0 is offline  
post #8 of 29 Old 07-14-2013, 06:55 PM
Bump To Pass!!




 
toren302's Avatar
 
Join Date: Jan 2010
Location: Monroe, WA
Posts: 9,708
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Quoted: 425 Post(s)
Thanks: 113
Thanked 783 Times in 699 Posts
Feedback Score: 1 reviews
What are you seeing for ICP numbers when WOT? Also IPR% would be good too. Sounds like HPOP to me. Just did one on a customers truck that did the same thing. It started the same hot as cold but would only build 1700 psi when WOT. Pumps front seal was blown.





Quote:
Originally Posted by kafleming19 View Post
Almost time.

Mike, is the pull machine ready?
toren302 is offline  
post #9 of 29 Old 07-15-2013, 11:16 AM Thread Starter
Member
 
Join Date: Jun 2013
Location: Breaux Bridge
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If seal is blown would it be leaking from the truck? I dont have gauge on my hpop but oil pressure gaige on dash is always in the middle. Im only gettin about 15 pounds of bosst and wot. And I no the exhaust has a roar to it when im cruisin. I can be cruisin at about 45 and push the throttle about half way and boost will go up but truck will lag about 5 secs then start to pick up speed. The exhaust sounds the same as it did last time that the turbo was sticking

03 f350
ARP Studs
Coolant Filter
DC Power inc Alt.
FICM with Reflash
Edge Juice
EGR Delete
Oil Cooler
Fuel Press,EOT,ECT Gauges
40 Inch Toyos
10 inch lift
Straight 4" back with 7" Mbrp tip
LAredneck6.0 is offline  
post #10 of 29 Old 07-15-2013, 04:11 PM
Compression Ignition Addict
 
ps_lane01's Avatar
 
Join Date: Feb 2012
Posts: 596
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Did this happen out of the blue? Progressively get worse? After a mod? Sounds like a boot or exhaust leak. Very well could be hpop as well.. Gotta share some scan results or its a wild goose chase.


Sent from AutoGuide.com App


2003 Silver 6.0L PSD CC/SB FX4
EGR Delete, Oil Cooler upgrade
Blue Spring & Banjo Bolt Upgrade
AFE Stage II Intake, MBRP Straight 4" Turbo back
RBP 6" tip
SCT Custom Tuned
Autometer GS series
BFG A/T 285s
Recon Smoked Cab Lights
Recon Interior L.E.D.
Recon 3rd Brake L.E.D.
Custom Fiberglass Center Console
Two 10" Sundown Sa4's, Hifonics 1200 RMS mono
Optima Batteries
Meyers 7.5C Plow
ps_lane01 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome