Tbc fault no electric brake power. - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-06-2013, 01:13 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tbc fault no electric brake power.

I noticed the tbc fault code a few times when I drove the truck around with no trailer. Never paid any mind to it cause the truck ran fine.

It wasn't until now that I'm trying to get my trailer inspected when I noticed the trailer brakes weren't working. Chased all the wires and even ran power direct to the brakes to eliminate the trailer. The brakes do work. When I checked the connector at the bumper I noticed the brake prong wasn't getting power when the brakes were pressed on in the truck.

The manual says there's a break in the electric brake wire somewhere. My best guess is either a blown fuse or a wire broken somewhere. Anybody got an electrical diagram or can point me in the right direction? Thanks

Sent from AutoGuide.com Free App
Jesse302boss is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-16-2014, 08:34 AM
Powerstroke.org Rookie
 
Join Date: Jun 2007
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bump for same issue

I have the same issue and mine's an '07 with tow command. I've checked all the connections (7pin, MC sensor, etc.). My next move is probably replacing the MC brake pressure sensor. Anyone have the part number for it and the ITBC module.
kjunior is offline  
post #3 of 3 Old 06-19-2014, 06:18 AM
Powerstroke.org Rookie
 
Join Date: Jun 2007
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fixed it

Well, my local dealership matched Tasca's price on the transducer. The dealer wanted $133 and came down to $88. Installed it with minor work and no more TBC fault. I took apart the dash to check the connections on the ITBC and in anticipation of having to replace it, but it was a waste of time. In case you need it, here's the P/N (2L1Z-2B674-AA)
kjunior is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome