2004 Exc 6.0 Slow/No Crank - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-23-2013, 04:00 PM Thread Starter
Powerstroke.org Fanatic
Join Date: Apr 2010
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2004 Exc 6.0 Slow/No Crank

2004 Excursion 6.0

Truck has been sitting up off and on for four years. Batteries had been doing ok till last 8 months. Went to start up last week. Put charger on both bat's till fully charged. Slow slow slow crank with click. So I thought batteries just quit.

put 2 new hot batteries on and same issue.

pulled bat's and put on 05 f350. starts fine.
put 05 bat's on exc and same issue.

Figure its starter (had this issue out of 00 7.3 couple of years ago)
but wanted to see if there might be something else Im missing.

Truck ran fine when parked just seemed like bat's didnt stay charged more than 3 days. Even after upgrade to 140 amp alt.

2000 F250 7.3 "Ol' Faithful"
2004 Ex 6.0 "Tha Turd"
2004 F 250 "Beast"
jhenson is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome