No power from dead stop - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2013, 01:43 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No power from dead stop

This problem has been on going for a few months. I had the Turbo, FICM and injectors replaced by Ford. Every since I have only been getting about 7-8 MPG around town and when you push the pedal to the floor it won't get out of its own way. I'm not getting a check engine light. Any help would be great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-22-2013, 11:11 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2013
Location: Whidbey Island, WA
Posts: 132
Thanks: 3
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Could be low fuel pressure, stuck vanes (probably not with a new turbo), thermostat stuck open, clogged EGR, clogged catalytic converter and etc. Are you running any gauges other than what Ford provided? Any boost leaks on the intake side? Any leaks on the exhaust side?
Reply With Quote Quick reply to this message
  #3  
Old 05-22-2013, 04:52 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel Pressure might be it. I went back over the service tickets and I didn't see where they replace the fuel filters. I ordered a set a couple of days ago. Only have the factory gauges and it doesn't seem to be running hot, not even under a heavy load. I will let you know if that does the trick. No leaks on the Turbo or the exhaust side. I replace the turbo to intercooler boots a few months ago with the turbo. Also had the EGR cleaned.

Last edited by sad6.0L; 05-22-2013 at 04:55 PM.
Reply With Quote Quick reply to this message
  #4  
Old 05-22-2013, 05:41 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I found the fuel filter to be pretty plugged. As well as the air filter being ripped. I ordered a new ones from summit and should have them in the morning. It has an AEM Brute Force filter that just came apart when I grabbed it. I have to drive to Salt Lake on Friday with a load so I don't want to get stranded.
Reply With Quote Quick reply to this message
  #5  
Old 05-23-2013, 06:55 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2013
Location: Whidbey Island, WA
Posts: 132
Thanks: 3
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Yeah, keep us updated. I installed a Fuel Pressure gauge about two weeks ago and found that my fuel pressure is around 45-48psi at idle and can drop below 40psi at WOT. I know my fuel filters are good because I replaced them about 2000 miles ago. And so I suspect my spring is weak and have ordered a blue spring. I'm really really hoping that installing the blue spring will bring up my FP and have a good side effect of providing more power because right now it's kind of a dog off the line.
Reply With Quote Quick reply to this message
  #6  
Old 05-23-2013, 10:42 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Change both filters this morning. Seems to be better. I will know more tomorrow. I have to make a haul to Salt Lake and that will let me know for sure.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:35 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors