2003 bucking up hill and loosing boost...... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-10-2013, 11:54 PM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question 2003 bucking up hill and loosing boost......

Was pulling about a 6% grade after about 1:30 of driving through the hills in my 2003 ex when it started bucking like maybe there was a miss. All my gauges looked good and no engine lights except my boost would drop from around 17 psi to 10-12 at each buck or miss or whatever it was. I'm not really sure what it was since I'm new to my diesel having issues.

The coolant, filters and everything has recently been changed and my deltas have been a solid 9 degrees. I have been running the ford cetane booster for the past 1500 miles too. And I have replaced the coolant cap with the updated ford part. This was my first real test running it through the hills so I'm at a loss.

It has been having the 50-75 rpm surge at idle though once hot. So any questions? The rig has about 96k miles on it. Thanks!!!
Ndekens is offline  
post #2 of 4 Old 05-11-2013, 12:23 AM
Powerstroke.org Fanatic
 
chris-rector's Avatar
 
Join Date: Oct 2010
Location: Centennial CO
Posts: 142
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have a 03 as well mine was Bucking alot my going about 45 miles an hour finally one cold snowy day here in Colorado I was driving the hill and it just lost all power died I restarted it still have no power looks like I'm in for a HPOP replacement

Sent from AutoGuide.com Free App

<a href="http://truckprofile.com/members/chris-rector/Ford-F350-2003/694">My Truck Profile</a>
chris-rector is offline  
post #3 of 4 Old 05-11-2013, 08:52 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So is this typical of the bucking to indicate an hpop failure? Anyone know what the typical cost is to have the dealer replace it?
Ndekens is offline  
post #4 of 4 Old 05-12-2013, 02:05 PM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Just checked the fcim and its holding a solid 47.5.... Thinking hpop or a leak in the hpop circuit.
Ndekens is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome