new powersteering pump gone bad?? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-01-2013, 04:27 PM Thread Starter
Compression Ignition Addict
Join Date: Jan 2013
Posts: 492
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
new powersteering pump gone bad??

Hi i have. 04 f350 6.0 and i think the new powersteering pump that i had installed went bad/blew a line. I think this because ive noticed a small drip under the truck. I crawled.under it and some parts are wet. I looked around on top of the motor and have noticed that the powersteering fluid appears to have puked fluid through the cap and that the line that runs across the top part of the motor appears to be punctured or blown. Any thoughts or ideas on what i should do?
powerstroken00b is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome