04 6l - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-16-2013, 07:04 PM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04 6l

i did head studs and gaskets about 3k ago annd the icp acted up about a week ago so i drove it surging for the week till i had timne to change it last night. today it thriugh a cylinder 3 contribution code and when it was first started with a 7k lb trailer on it it would not pull itsself out of the drive way. i had to use 4low with hubs unlocked for the reduction untll i got on the road for first 500 feet. put back in two hi and it ran gerat after the first 3 or 4 km untill it warmed up it seemed
bull.rider is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome