Computer issue question? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-16-2013, 02:03 PM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Computer issue question?

Ok so here's the problem I am having. I have a 2003 6.0l powerstroke and ill be driving down the road or on the highway and it will randomly turn on tow/haul mode with the orange light blinking on and off. It won't shift at all when this happens usually. Another thing that happens sometimes is on the highway ill be going around 70mph and it will randomly have the tow/haul thing again and itll go to shift and itll get stuck in neutral or something and if i hit the gas it just revs and then eventually slam really hard into a gear and stay in that gear. I have an sct and it runs various codes. I have ran it at times on a custom tune with it running fine then this happens and then return it to stock and runs fine for a little and even a strategy tune which i was running over a weekend trip down to myrtle beach which was 8 hours with it running fine and then today it flipped out again. Let me know if anyone else has had this problem or knows of what the problem is. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-16-2013, 02:14 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,416
Thanks: 110
Thanked 140 Times in 138 Posts
Feedback Score: 0 reviews
Ill bet the blinking lights are all codes the truck is trying to send you. My old Pete i used to drive would blink like this. When I mentioned it to the mech he told me to write down how many blinks and what blinked. Sure enuff truck was just talking Peterbilt to me and I was to dumb to know.
Reply With Quote Quick reply to this message
  #3  
Old 04-16-2013, 02:46 PM
Premium Member


 

Join Date: Aug 2012
Location: Fort Knox, KY
Posts: 245
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thats true, its letting you know theres a problem with the transmission. You need to have the codes pulled from the transmission controller and see. A lot of the times its a failing trans temp sensor. You can also return the tune back to stock and see if it helps.
Reply With Quote Quick reply to this message
  #4  
Old 04-16-2013, 03:38 PM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i've ran the truck on stock before and it does the same problem. I know it prolly isn't good for the truck but i keep switching between the tunes until it freaks out again and then change it. I just had the tranny rebuilt by a powerstroke mechanic trusted maybe 2000k miles ago. And last time i had it in the shop i had him check everything and nothing came up. Ill run it tomorrow and see what codes my sct will pick up maybe thatll help with the answer
Reply With Quote Quick reply to this message
  #5  
Old 04-16-2013, 05:16 PM
Premium Member


 

Join Date: Aug 2012
Location: Fort Knox, KY
Posts: 245
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did some searching and found that most times it the trans temp sensor, it causes the trans to go into a limp mode. If you conclude that its the sensor its not a hard fix although it is in the trans above the pan.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:14 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors