03 6.0 with multiple issues - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-11-2013, 01:39 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 6.0 with multiple issues

I have an 03 F250 6.0 that I just picked up with 140K miles. It has multiple issues unfortunately (what a shocker).

1. She smokes a good amount of blue when I cold start it. It seems to cut out lightly on acceleration and does it worse the slower I accelerate. Also kicks and bucks when accelerating in overdrive, I guess the best way to describe it is if any of you have had a coil pack go out on a 5.4 and how that kicks and bucks in overdrive. Again, its worse the slower I accelerate.

2. After sitting anymore than an hour, the power locks won't work.

3. The power mirrors won't adjust outward, I think it could be the switch.

4. The "miles until empty" is way off, maybe it needs to be recalibrated?

5. Number 115 fuse (trailer tow battery charge) which is supposed to be a 20amp was blown. It had a 30amp in its place which was blown, and with the truck running I replaced it with a 30amp and it blew immediately. That may have been my idiot fault for installing it while running?

6. The radio sometimes stays on after I shut the truck off and open the door.

I believe thats about it. Here are some details on the extras on the truck, it has a newer BOSS plow (lots of wiring), a trailer brake controller that I had to unplug because it was making a ticking noise and blinking constantly. It also has extra back up lights and an orange beacon on top of the Cab rack. I have a feeling some of these extras are whats killing my electrical situations. It also has a brand new 135amp alternator.

Sorry for so much to ask, but I would love any help I can get! Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-11-2013, 02:55 PM
Premium Member


 

Join Date: Aug 2012
Location: Fort Knox, KY
Posts: 245
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1. Check FICM Voltage
2. ???
3. Most likely the switch
4. Lie-o-meters are rarely accurate
5. Check all aftermarket trailer hitch/plow wiring.
6. Normal, system will keep radio on after key is off for 10 minutes, unless a door is opened sooner.
Reply With Quote Quick reply to this message
  #3  
Old 04-14-2013, 08:38 AM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by PHYRMN View Post
1. Check FICM Voltage
2. ???
3. Most likely the switch
4. Lie-o-meters are rarely accurate
5. Check all aftermarket trailer hitch/plow wiring.
6. Normal, system will keep radio on after key is off for 10 minutes, unless a door is opened sooner.
I removed every bit of aftermarket wiring I could find and am still having every problem. The radio stays on even after the door is opened. I have yet to check FICM voltage though
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors