04' 6.0 turbo issues - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-01-2013, 08:50 PM Thread Starter
Join Date: Nov 2012
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04' 6.0 turbo issues

Okay i had alot of help on here last time with a previous problem i had so im hoping to have the same results. Alright, i just rebuilt the engine in my truck. Stock bottom end, stock turbo, head studs, egr delete, the usual.. Now when you go down the road you can here the turbo going in and out. It doesnt completley go away it just isnt spooled up like it was. I have absolutley no codes what so ever. When you are on a highway and pretty much using the boost to pull you down the road, thats when it does it the worst. When it sounds like it goes away, i try to give it more fuel so it will try and spool back up but it acts like it isnt there at all unless i push the pedal down so far that it kicks down the trans and the rpms raise forcing it to spool back up. I am really at a loss with this one. When i tore the truck apart i noticed that the turbo said REMAN on it, so apparently its been replaced. I would greatly appreciate it if someone could at least give me a direction to go in. Thanks.
JasonSeaton2004 is offline  
Sponsored Links
post #2 of 3 Old 04-05-2013, 06:56 PM
Compression Ignition Addict
06Lariat_'s Avatar
Join Date: Jan 2013
Posts: 321
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Maybey the vanes are sticking?? Did u clean the turbo? Btw my turbo says remanufactured as well

06 Lariat SuperCab Long Bed

Leveling kit
Chrome bug deflector
Tri-Fold tonneau cover
4" MBRP turbo back straight pipe
Smoked cab lights
Blue spring upgrade
Riff raff boots
Edge insight cts overhead mount

06Lariat_ is offline  
post #3 of 3 Old 04-05-2013, 07:00 PM
Premium Member

PHYRMN's Avatar
Join Date: Aug 2012
Location: Fort Knox, KY
Posts: 252
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any high pressure air sounds or squealing sounds under the hood? Might be a cracked Y Pipe.

2003 Excursion Eddie Bauer 6.0l 4x4 | 2004 Intake | Zoodad Mod | Upgraded HPOP Cover | ARP Studs | OEM Headgaskets | Updated Turbo Feed-Drain Tubes | EGR Delete | Coolant Filter | Altas 40 | MKM Street Tune | Banks 4" CAT Back | Muffler Delete | High Idle Mod | Blue Spring Update | 6.4 Banjos | CCV Mod | Glowshift Gauges (Boost, Oil Press, Coolant Press, EGT, Volts, Fuel Press) | Rotella ELC | Rotella T6 | V/B Springs | Torque App on ASUS 10" Tablet |
PHYRMN is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome