Fuel problem, stumped - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-27-2013, 08:06 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry Fuel problem, stumped

Well shoot, I have had the worst luck with this truck. 2004(late model) crew cab short bed. Egr delete, airaid intake, studs. I have done studs(twice) on this thing in a matter of 15,000 miles without running a tuner. Heads were pressure checked and milled within ford tolerances the second time. Leaves me no money for fun stuff whith this thing!
So I finally got it all back together and when doin so I noticed two of the injectors were slightly darker than the other 6. I replaced all washers and seals and cleaned the two off hoping it was just a sealing issue. All back together ran like a dream. after about 25 miles CEL came on, found out i forgot to plug in my ICP, whoops! I put about another 2000 miles on then rough idle, hard starts, and eventually stalling apearred. Took it to ford and had a contribution test done. The two injectors (#2,#4) I had suspicion about failed. Along with a icp code and the egr code which I expected. Replaced the two injectors (old ones were black). Ran great. Another 300 miles, exact same symptoms...help??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-27-2013, 08:43 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,589
Thanks: 5
Thanked 102 Times in 97 Posts
Feedback Score: 2 reviews
So you now have injectors failing randomly?
Reply With Quote Quick reply to this message
  #3  
Old 03-28-2013, 01:34 AM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I guess so, it has the exact same symptoms of my previous two that failed. When I got the contribution test done the first time, those were the only injectors skipping a beat.

Ps. I forgot to mention I have the blue spring upgrade and am running rev x.
Reply With Quote Quick reply to this message
  #4  
Old 03-28-2013, 01:37 AM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I guess so, it has the exact same symptoms of my previous two that failed. When I got the contribution test done the first time, those were the only injectors skipping a beat.

Ps. I forgot to mention I have the blue spring upgrade and am running rev x.

Thanks for the reply
Reply With Quote Quick reply to this message
  #5  
Old 03-29-2013, 06:39 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 538
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Why do you have an icp code? And your injectors shouldnt be failing within that amount of use... Meaning your mechanic should have given you a printout or atleast told you what the contributions on all of the cylinders and injectors are so your not surprised with more failing injectors. Whats your oil pressure like?


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #6  
Old 03-30-2013, 01:09 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When it was put back together, the sensor wasn't plugged it, ran it for a bit until I found out and then plugged it in, I never had the code cleared. Oil pressure is good, no issues, fresh fluids and motorcraft filters all around, only have 700 miles on them. The dealership gave me ~10 pages of stuff back including the contribution test results, it showed cylinder 2 was nearly dead and 4 was on the way out, so I replaced both to be safe. All other injectors passed. It feels like it starts fine, then 5 seconds in it clicks over and rough idles, progressively getting worse, then cuts out. Vacuum lock? Air in fuel system? I'm just lost...
Reply With Quote Quick reply to this message
  #7  
Old 03-30-2013, 02:18 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 538
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Do a search on here for air in fuel or fuel rail leak... Theres a process of removing ficm and fuel pump relays, crank it, and look for air bubbles in the upper fuel filter housing... if there is you could have a fuel rail-injector seal or injector cup leak resulting in air being pushed back into the fuel system. Can u possibly measure your fuel pressure and oil pressure while cranking and then when it idles rough and get back to us?... Actual readings are very helpful :-)


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #8  
Old 03-31-2013, 09:05 AM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, I broke down at took her in to the dealer. I did find a leak but couldn't determine the source. They said the same thing and say my number 2 cylinder has an injector cup issue, yet it's not cracked. Not sure what that entails... I really appreciate your help!
Reply With Quote Quick reply to this message
  #9  
Old 03-31-2013, 09:30 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 538
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Hey no problem


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
6.0, fuel, rough, stall

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:28 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors