No 4wd also tow/ha flashing - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-10-2013, 09:08 PM
Member
 

Join Date: Dec 2012
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No 4wd also tow/ha flashing

2003 ccsb

Got done putting truck all back together after head studs and all that, drove it 900 miles to Idaho for snowmobiling...I get into snow goto turn to 4wd and nothing. No light nada
So I figure it has to do something with the two relays in the box behind drivers battery since when i power washed the truck with he cab off water got in it and when we hooked batteries up some sizzling and smoke came out.

So I pull both out to test them (ohm out) find one is bad...but figure ill replace both well I didn't make it to the auto store in time and forgot about the relays and went a 1/2 mile away to he store...let the truck idle for 5 min and get and the tow/haul was flashing truck felt like it starts in a high gear and shifts hard also shifts hard into reverse....is this due to the relays I left out I'm guessing and also is his my 4x4 problem you think?? It's the smaller black one in the picture closer to the battery.
Thx
Attached Thumbnails
No 4wd also tow/ha flashing-image.jpg  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors