03 No electrical power - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 02-28-2013, 05:18 PM Thread Starter
Powerstroke.org Fanatic
 
Sno-Mow's Avatar
 
Join Date: Jan 2012
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
03 No electrical power

So I got my cab lowered back on today and everything hooked up and went to hit the key...NOTHING!!

Checked the batteries and checked good, checked all wiring harnesses and all hooked up, checked battery connections. Decided to check fuses with a test light...NO POWER TO ANY FUSES!!

I've been checking wires for 5 hours and just don't know. Any ideas? There is no cab light, no dash lights, no radio. Its almost like the batteries are dead, but they're good...they were on the charger for 2 days and even checked them with the Snap On battery tester.

Getting really frustrated and need ideas. I was thinking PCM.

2003 F250 6.0l
281,000 miles and counting
EGR Cooler Delete, A1 Studs, 3.5" Down Pipe, 4" Straight Pipe, Turbo Rebuilt, New OE Heads, New HPOP, New Injectors
Blizzard 8611PP Because you won't push it with a gasser!



http://www.facebook.com/SnoMowServices
Sno-Mow is offline  
post #2 of 9 Old 02-28-2013, 05:53 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 62 Times in 58 Posts
Feedback Score: 0 reviews
Ya shure you got all the plugs and wires hooked back up? All the grounds too.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #3 of 9 Old 02-28-2013, 05:58 PM Thread Starter
Powerstroke.org Fanatic
 
Sno-Mow's Avatar
 
Join Date: Jan 2012
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Everything is hooked up. I thought maybe that was the case so checked all the harnesses (all 8 of them that got disconnected) and all the grounds (motor to cab, cab to frame, batteries to frame). I even cleaned the ones that got oil on them just to make sure that wasn't the issue.

I am stumped. I do have an extra PCM sitting around I may try seeing as they only take 5 minutes to swap out.

2003 F250 6.0l
281,000 miles and counting
EGR Cooler Delete, A1 Studs, 3.5" Down Pipe, 4" Straight Pipe, Turbo Rebuilt, New OE Heads, New HPOP, New Injectors
Blizzard 8611PP Because you won't push it with a gasser!



http://www.facebook.com/SnoMowServices
Sno-Mow is offline  
post #4 of 9 Old 02-28-2013, 08:26 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 62 Times in 58 Posts
Feedback Score: 0 reviews
Mebe possible but electrical flow is from fuse box too pcm and back.
Do you have any power at all?


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #5 of 9 Old 02-28-2013, 08:32 PM Thread Starter
Powerstroke.org Fanatic
 
Sno-Mow's Avatar
 
Join Date: Jan 2012
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Nothing at all. PCM relay maybe? I was just looking at a wiring diagram and was thinking that or ignition switch. But on the diagram it shows "vpwr" seems to be common in most relays. Any idea what that stands for?

2003 F250 6.0l
281,000 miles and counting
EGR Cooler Delete, A1 Studs, 3.5" Down Pipe, 4" Straight Pipe, Turbo Rebuilt, New OE Heads, New HPOP, New Injectors
Blizzard 8611PP Because you won't push it with a gasser!



http://www.facebook.com/SnoMowServices
Sno-Mow is offline  
post #6 of 9 Old 03-01-2013, 11:57 PM Thread Starter
Powerstroke.org Fanatic
 
Sno-Mow's Avatar
 
Join Date: Jan 2012
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Re: 03 No electrical power

Found it! Battery cable was tucked under battery box and not visible. I found it when I was looking to fix another wire I found broken after I pulled the inner fender out.

2003 F250 6.0l
281,000 miles and counting
EGR Cooler Delete, A1 Studs, 3.5" Down Pipe, 4" Straight Pipe, Turbo Rebuilt, New OE Heads, New HPOP, New Injectors
Blizzard 8611PP Because you won't push it with a gasser!



http://www.facebook.com/SnoMowServices
Sno-Mow is offline  
post #7 of 9 Old 03-02-2013, 03:11 AM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 62 Times in 58 Posts
Feedback Score: 0 reviews
Glad ya found it cause I was running out of ideas LOL


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #8 of 9 Old 03-02-2013, 03:58 AM
Compression Ignition Addict
 
BIG Laing's Avatar
 
Join Date: Sep 2012
Location: Ogden, UT
Posts: 2,482
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Sno-Mow View Post
Found it! Battery cable was tucked under battery box and not visible. I found it when I was looking to fix another wire I found broken after I pulled the inner fender out.
Wait wait wait. You didn't realize the battery wasn't hooked up? Sorry I found this funny. After doing the whole cab off and getting everything else right, you forgot to plug the battery back in...

Glad you got it figured out.

2013 Lariat Eco-Boost F150 Super Crew 4x4 5K Miles. Max-Tow 3.73's, luxury package


(Sold) 2011 Lariat 6.7 F350 CCLB SRW 4X4 60K MILES
Nitto Terra Grappler 295/70/R18 on OEM's
BIG Laing is offline  
post #9 of 9 Old 03-02-2013, 04:40 AM Thread Starter
Powerstroke.org Fanatic
 
Sno-Mow's Avatar
 
Join Date: Jan 2012
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Re: 03 No electrical power

Quote:
Originally Posted by BIG Laing View Post
Wait wait wait. You didn't realize the battery wasn't hooked up? Sorry I found this funny. After doing the whole cab off and getting everything else right, you forgot to plug the battery back in...

Glad you got it figured out.
Not the main cable. The one that gets attached to the 10mm nut. Damn thing was between the fender and inner fender.

Sent from AutoGuide.com Free App

2003 F250 6.0l
281,000 miles and counting
EGR Cooler Delete, A1 Studs, 3.5" Down Pipe, 4" Straight Pipe, Turbo Rebuilt, New OE Heads, New HPOP, New Injectors
Blizzard 8611PP Because you won't push it with a gasser!



http://www.facebook.com/SnoMowServices
Sno-Mow is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome