Hid problem - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-16-2013, 04:05 PM Thread Starter
Member
 
Join Date: Nov 2012
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hid problem

So I installed a hid hi/low beam kit for my dad in his 04 f350 and they don't switch and the high beam light on the dash stays on. Any help
rogco is offline  
post #2 of 3 Old 02-16-2013, 04:08 PM
Bump To Pass!!




 
toren302's Avatar
 
Join Date: Jan 2010
Location: Monroe, WA
Posts: 11,247
Thanks: 122
Thanked 904 Times in 803 Posts
Mentioned: 141 Post(s)
Quoted: 1154 Post(s)
Feedback Score: 1 reviews
Had this exact same problem. I went through 3 diffent kits before I found the one that works. The relay that comes in the kit is wired wrong. The kit I found was on ebay. Work great but that was 2 years ago.




toren302 is offline  
post #3 of 3 Old 02-16-2013, 04:09 PM Thread Starter
Member
 
Join Date: Nov 2012
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well that sucks haha
rogco is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome