Do you think i have a bad GPCM?? - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-08-2013, 02:44 PM Thread Starter
Premium Member

 
1fastsvt0816's Avatar
 
Join Date: Mar 2009
Location: Detroit
Posts: 212
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
Do you think i have a bad GPCM??

Ok, a week or so ago i finished my head gaskets (cab removal). I also replaced all the glow plugs (Motorcraft) and both harnesses since i had the truck apart. The day after i finished the head gasket job the truck threw a P0676 code (cylinder 6 glow plug circuit failure). I cleared the code and it just comes back. I swapped the 2 connectors on the GPCM and threw a code P0683 (GPCM to PCM communication circuit). I then put the two connectors back to normal on the GPCM, cleared the code and now its throwing the first one again. Do you guys think i might have a faulty GPCM since i have all new glow plugs and glow plug harnesses???
1fastsvt0816 is offline  
post #2 of 4 Old 02-08-2013, 05:18 PM
Powerstroke Techie

 
Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,825
Thanks: 33
Thanked 143 Times in 129 Posts
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
Garage
Feedback Score: 4 reviews
possible one of the harnesses isn't seated all the way? they can be tough to push in sometimes.

Start with a resistance check at the glow plug harness connectors. A good glowplug should be around 2 ohms to ground

-Matt

Ford Senior Master Tech

2015 F-250 XLT 6.7L

2006 F-250 6.0L SOLD
sinner6.0L is offline  
post #3 of 4 Old 02-11-2013, 11:46 AM Thread Starter
Premium Member

 
1fastsvt0816's Avatar
 
Join Date: Mar 2009
Location: Detroit
Posts: 212
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
Thanks man. I'll check that this week. It starts and round fine, just have that code coming up. Hopefully that's it. If the plug is seated on the glow plug would that mean I could have a faulty GPCM?
1fastsvt0816 is offline  
post #4 of 4 Old 02-13-2013, 01:27 AM Thread Starter
Premium Member

 
1fastsvt0816's Avatar
 
Join Date: Mar 2009
Location: Detroit
Posts: 212
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
ok, so last night i disconnected the black harness on the GPCM (for the even numbered cylinders) and did an ohm test. All glow plugs tested right at 1 ohm. Before this i pushed down on the glow plug connectorr, the angle my arm was at i couldnt tell if any of them pushed in any. I cleared the check engine light, if it comes back with a GP code, could i suspect the GPCM is faulty?
1fastsvt0816 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome