3 codes and some trouble - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-24-2013, 11:55 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
3 codes and some trouble

Hello all. Been lurking around on the site for some time but have decided to join so I can post and help others here and there. I have a problem with my 2007 6.0. Has about 135k on it. So far I have only replaced one injector, kept up on oil changes, did fuel filters mid last year or so, mostly country and highway mileage with some towing and plowing.

Anyways, the past day or so my check engine light came on. Scanned it and pulled the following codes:
p0404-says EGR Control Circuit

P0266- says Cylinder 2 contribution/balance

P0528- Fan Speed Sensor

I havent had much trouble driving the truck. I know I need new glow plugs because unless I plug the truck in at night its a VERY hard start the next cold morning. I also have noticed that if I'm driving and stop at a light, when I go hit the accelerator to pull off a stop there is a second or two of hesitation, almost like the truck has to burp or it missed. Injector going again? Not sure what the deal is......??

I should note that May of this past year (2012) the HPOP blew on me and was replaced. While the motor was apart the tech cleaned the EGR out completely.

Pulled the EGR valve as recomended by a ford tech- little bit of soot but not super caked, valve still moved fine. Cleaned it up and re-installed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-24-2013, 02:22 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: 3 codes and some trouble

First it looks like your connector or wiring is bad to the egr/or cooling fan, which may affect fan operation, or the egr valve is bad. Glow plugs are rarely the reason a truck will not start smoothly unless you are in very cold conditions, more than likely your ficm is taking a hike. Load test your batteries and perform the ficm check procedure. And for god sakes, get a monitor on the truck.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #3  
Old 01-24-2013, 02:33 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I see alot of ads for "$100 FICM Repair" listed all around this site. Is it worth doing something like that? I saw the sticky thread on how to test the FICM, havent done that yet
Reply With Quote Quick reply to this message
  #4  
Old 01-24-2013, 03:02 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: 3 codes and some trouble

Quote:
Originally Posted by srl28 View Post
I see alot of ads for "$100 FICM Repair" listed all around this site. Is it worth doing something like that? I saw the sticky thread on how to test the FICM, havent done that yet
Great reviews from ed at ficmrepair.com. Check out his website. Make sure you test it cold.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #5  
Old 02-05-2013, 02:05 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok so I did Eds test to test the ficm. The usual with the DC volt meter. Came up with right at 48 volts give or take about .1 or so here and there. Still a f'd up ficm?

Pulled the EGR valve for the second time in the last two weeks and cleaned it. Not bad, covered in soot but not caked or anything bad.

The symptoms are still the same pretty much. Won't really start unless its plugged in when its cold. After sitting at a light or something it will blow a puff of black smoke, and occasionally when driving it will do the same (going up a hill, around a bend). Other than the puff of smoke and slight hesitation when pulling off a stop at a light you wouldnt know something was up, truck runs ok.

This truck is a work truck for us, plows snow. We have a big snowstorm coming at the end of the week and I need this truck out there working without flaw. I need to know tonight what my next move is so I know if I should order a ficm from ficmrepair.com or not so it makes it here in time. help!
Reply With Quote Quick reply to this message
  #6  
Old 02-05-2013, 02:47 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: 3 codes and some trouble

So your batteries load tested ok? The logic side of the ficm can go bad, not sure how that is tested. It may help to call ed and get his opinion. Have you done anything recently to your truck?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #7  
Old 02-05-2013, 02:56 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Haven't load tested the batteries yet. Probably should have but wasn't sure what the best way to was

As for recent work. Two weeks ago I did a trans temp sensor and in the spring had the hpop done. #7 or #8 injector was done last winter. Forget which one
Reply With Quote Quick reply to this message
  #8  
Old 02-05-2013, 04:53 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: 3 codes and some trouble

You can take the batteries to most places that sell batteries, they can load test them. It is best to get a readout vs them just telling you
They are good/bad. Do you have a monitor comparable to these........Write Up: Monitoring the 6.0L PSD.
It would be good to see icp and ipr%, ficm v while cranking cold, ficm v while idleing/driving cold, and batt v cranking cold.




Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #9  
Old 02-05-2013, 05:08 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks! Appreciate the help, I'll give that a shot tomorrow.

I spoke with Ed tonight from ficmrepair.com. He suggested I check the ficm voltage when the engine is absolutely cold. Today when I tested it the truck had just been running 20 minutes or so before that. I still feel that most signs point to the ficm going bad on me and in the interest of time because of the impending storm, I may just go ahead and order the ficm and get that in there asap. It came to mind while talking to him tonight that over the summer this trucks alternator crapped out and completely died. Truck repair place was able to recharge the batteries pretty well but I'm sure now that the damage to the ficm was done.

Ed recommended the Atlas 40 upgrade when I pickup the new ficm- Can anyone add any insight to this?
Reply With Quote Quick reply to this message
  #10  
Old 02-05-2013, 05:54 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: 3 codes and some trouble

Ok, l suggested to do it cold from the start. Lol. Everyone that has the atlas 40 ficm tune seems to be happy. Keep us updated.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors