2005 motor problems, turbo etc - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-16-2007, 05:55 PM
Powerstroke.org Rookie
 

Join Date: Oct 2007
Location: Sutton, MA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 motor problems, turbo etc

hey guys, girls. My first post so bear with me.
I have two f series trucks, a 350 p/u and a 550 dump. The dump is for towing and I had installed an Edge module with the Attitude monitor. This really improved the towing. I tow on average 14-16000 lbs. No problems until it reached 35k miles. I had the check engine light come on and the edge system would go blank. It would be like driving with 4 cylinders. Dead!!! Then it would come back on again and all would be fine. ???? go figure. I brought it in to Ford and they were lost for words. They shut the check light off and reset the truck. I got the black box from them and it showed the speed sensor was bad, replaced it. Ok for a while then BAM again and again it happened. I noticed that my temp was going way up and the coolant was coming out of the cap. They replaced the fan clutch, turbo, speed sensor, oil cooler and some other cooler. Still the same problems. I disconnected the edge system all together. Now experiencing low power output and the turbo is not going up to its full potential.
Now they are putting in new head gaskets to see if this will help.
Does anyone have any input for me??
Thanks, Doug in MA
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-16-2007, 05:59 PM
Jon
Guest
 
Posts: n/a
550

its a crap shoot with the 550's. Mainly cuz they are so heavy even by themselves that they are working from the time you step on the pedal to the time you let off. Then you add the weight of the trailer in there. Head gaskets are an issue on 550's especially. I would buy a set of arp studs and have your dealer put them in while its apart.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors