Power loss - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2013, 02:45 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Power loss

Having power problems with my 074 f250. Mileage is great but no power feels like it is in limp mode but no codes. Under acceleration boost comes up to 20 and the engine revs but no sense of acceleration more of a stall. FICM is running 39 volts. I no its low but motor seems like it is trying to work but goese nowhere. Truck is bone stock with 16000 miles. Doese anyone have an idea where to start?
Pulled the boots off of the turbo and it seems like there is a lot of oil inside is this normal?

Last edited by mcpetrie; 01-05-2013 at 03:43 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-05-2013, 04:01 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: bel air, maryland
Posts: 1,964
Thanks: 4
Thanked 30 Times in 23 Posts
Feedback Score: 1 reviews
your ficm is shot and needs replacement asap. Ficm volts should never drop below 45 volts. Also when you get the ficm replaced, do a buzz test on injectors to make sure your injectors are operating properly.. Ficm's kill injectors fast. good luck... Call ed@ ficmrepair.com
Reply With Quote Quick reply to this message
  #3  
Old 01-05-2013, 04:14 PM
Serving Our Country!

 

Join Date: Apr 2012
Location: Florence sc
Posts: 983
Thanks: 7
Thanked 12 Times in 12 Posts
Feedback Score: 1 reviews
Send a message via Skype™ to Bluedemon6.0
Ficm is shot. I would not drive or try to start this truck until the Ficm is rebuilt.
Reply With Quote Quick reply to this message
  #4  
Old 01-05-2013, 04:48 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have been leaning toward the ficm and watching its voltage. It seemed like it layed down pretty quick even though the volts only dropped by 3. I apreciate your response and will have it repaired. I have a pretty cheap code reader but am curios what you guys recomend for a simple one that i can do the buzz test whith.
Reply With Quote Quick reply to this message
  #5  
Old 01-05-2013, 06:51 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: bel air, maryland
Posts: 1,964
Thanks: 4
Thanked 30 Times in 23 Posts
Feedback Score: 1 reviews
Go to a ford stealership and have them perform the test.
Reply With Quote Quick reply to this message
  #6  
Old 01-06-2013, 10:06 AM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for everyones advice. I am having the ficm repaired and will post if this has solved my problem.
Reply With Quote Quick reply to this message
  #7  
Old 01-12-2013, 05:11 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok went to remove ficm and found a loose harness connection. Locked it in place and am now showing 48.2 volts but still have same problem no codes but engine lays down in high end just like it is in limp mode any other ideas.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors