leaking coolant after egr delete - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-12-2012, 05:18 AM
Member
 

Join Date: Dec 2012
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
leaking coolant after egr delete

so i posted this on another forum but nobody really seemed to know so im posting it on this one.

i did a egr delete (welded it shut) and put it back in to make it look stock. i got it all put back together and started it up and i noticed that there was coolant running out the back of the right bank. i have no idea where from i trired looking but cant realy see. all i could see what to just below the right head. i tried tightening the rubber hose on the egr cooler and tried tightening the donut side. still nothing. i checked all of the freeze plugs and the ones that i see look fine and the onse i felt, felt fine

a uncle of mine is thinking maybe i bent one of those oh so strong stock head studs. me personally was thinking well then i would be getting coolant in my oil. but i have nothing. so im entirely lost here.

have any of you had this problem at all?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-12-2012, 05:43 AM
Premium Member
 

Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,941
Thanks: 0
Thanked 31 Times in 30 Posts
Feedback Score: 1 reviews
Coolant leaking from the egr cooler into the engine valley can run along the head/block line and look like the head is leaking. I'd look again at your coolant hose to the EGR cooler and at the egr coolant outlet O-ring. You did weld both ends of the cooler shut didn't you?


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
  #3  
Old 12-12-2012, 06:19 AM
Compression Ignition Addict

 

Join Date: Nov 2011
Posts: 1,829
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
ya dont weld just one end shut
Reply With Quote Quick reply to this message
  #4  
Old 12-12-2012, 06:52 AM
Member
 

Join Date: Dec 2012
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeap both ends are welded shut. i tried tightening those rubber hoses but i was thinking about just putting like a hose clamp on there. i was planning on doing studs anyways because im putting in some 155's and then gonna get some custom tunes
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors