Sputtering - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-09-2012, 11:38 AM
Premium Member

 

Join Date: Aug 2012
Location: Morgan Hill, CA
Posts: 641
Thanks: 58
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
Sputtering

Hi guys hope you guys can give me some advice as I am very green as a diesel owner. I recently changed oil/filter, fuel filters, and cleaned the airfilter. Now the truck sputter when going up thru the gears and smokes. I even let the truck warm up and it still does it. Seems like I have lost power too. It runs fine when out on the interstate...thanks guy ahead of time for any and all help

Sent from my DROID4 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-09-2012, 12:43 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
This is necessary.....Write Up: Monitoring the 6.0L PSD.

Just guessing without a monitor, check your egr valve, fuel pressure, ficm, or turbo sticking. You using racor or motorcraft filters with matching caps?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #3  
Old 12-09-2012, 12:56 PM
Premium Member

 

Join Date: Aug 2012
Location: Morgan Hill, CA
Posts: 641
Thanks: 58
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
I replaced everything with motorcraft except air filter that I just cleaned. What is rancor? Thanks again southend you've always been a great help to me....I do notice when it is sputtering that the turbo pressure goes way up...I blew out my knew so its gonna be hard to troubleshoot this one...lol

Sent from my DROID4 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #4  
Old 12-09-2012, 01:02 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
While we are on the subject, make sure your filter cap is stock. Racor is a filter brand, check out the video.....http://www.dieselfiltersonline.com/f...k-filters.aspx

Do you have a monitor, are you talking about the dash guage?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #5  
Old 12-09-2012, 01:20 PM
Premium Member

 

Join Date: Aug 2012
Location: Morgan Hill, CA
Posts: 641
Thanks: 58
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
The dash gauge. I haven't been able to afford a monitor yet...just not sure where to go....up to me purchasing the truck...the truck was serviced at a ford dealership. So I seen that the bad stuff that usually failed was replaced ie the turbo

Sent from my DROID4 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #6  
Old 12-09-2012, 01:22 PM
Premium Member

 

Join Date: Aug 2012
Location: Morgan Hill, CA
Posts: 641
Thanks: 58
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
Also when it gets into 3rd gear and I step on it the sputtering stops and runs fine...may mean nothing though just trying to share all the info

Sent from my DROID4 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #7  
Old 06-21-2013, 02:27 PM
Premium Member

 

Join Date: Aug 2012
Location: Morgan Hill, CA
Posts: 641
Thanks: 58
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
Ok I just replaced the fuel filters and been having a problem when the truck is cold that it runs horribly rough....Its been doing it for a while but it has gotten noticeably worse since I changed the fuel filters...with monitoring it with my edge insight I can't see anything out of the ordinary...I am very concerned about this and was wondering if this might have something to do with the HFCM...when I first started this thread it started doing this cold and rolling smoke out the exhaust after I changed the fuel filters..and now its even worse now that I have changed them again due to mileage...I have replaced them with motorcraft each time and am not sure what to do...I'm hoping someone out there can help me with this

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors