Thermastat Again? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-21-2012, 02:42 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Greeley
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Thermastat Again?

I just replaced my thermastat a month ago when I was flushed my coolant. Today got in my truck and couldn't get over 178 ect, my eot was around 195 this doesn't mean my oil cooler failed right?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-21-2012, 03:17 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
No it doesn't mean your oil cooler failed, oil in your coolant would be oil cooler failure. Check your two sensors after letting it sit overnight, they should be within a degree or so. That is called a cold soak. Maybe your temp sensor is bad. Did you install a motorcraft thermostat?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #3  
Old 11-21-2012, 03:38 PM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 17,397
Thanks: 64
Thanked 102 Times in 93 Posts
Feedback Score: 5 reviews
.......
Reply With Quote Quick reply to this message
  #4  
Old 11-21-2012, 03:57 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Greeley
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Ya its a motorcraft, I'll check the sensor In the morning like you suggested. I'll make sure to check the coolant to.
Reply With Quote Quick reply to this message
  #5  
Old 11-21-2012, 04:48 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Greeley
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I checked under the hood and there is some coolant that's leaked out of the degas. Does that mean anything, the motor has been studded. Maybe the cap?
Reply With Quote Quick reply to this message
  #6  
Old 11-21-2012, 04:56 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by sampson2269 View Post
I checked under the hood and there is some coolant that's leaked out of the degas. Does that mean anything, the motor has been studded. Maybe the cap?
Make sure your coolant level is at or below the min level. The updated coolant cap is all black with orange pictures on it. Was thee pressure on the system when you loosened the cap?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #7  
Old 11-21-2012, 05:21 PM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 17,397
Thanks: 64
Thanked 102 Times in 93 Posts
Feedback Score: 5 reviews
Could be just overfilled..(the new max is the min on the bottle)

Cap

Egr cooler

Head gaskets.


That is the order in which I would look at it.
Reply With Quote Quick reply to this message
  #8  
Old 11-21-2012, 05:24 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Greeley
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I have a bulletproof egr cooler and arp head studs so it shouldn't be either one of those right?
Reply With Quote Quick reply to this message
  #9  
Old 11-21-2012, 05:52 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by sampson2269 View Post
I have a bulletproof egr cooler and arp head studs so it shouldn't be either one of those right?
Black onyx gaskets, heads surfaced, pressure tested?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #10  
Old 11-21-2012, 06:10 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Greeley
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Yep all of the above, also have ipr coolant filter, I opened the cap and looked in with a flashlight the coolant is brand new elc and it seems to be a darkish brown now, but doesn't seem like oil. How obvious is the oil in the degas if oil cooler fails?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:40 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors